RFR: 8193559: ugly DO_JAVA_THREADS macro should be replaced [v4]
Kim Barrett
kbarrett at openjdk.java.net
Fri Jul 30 19:12:31 UTC 2021
On Fri, 30 Jul 2021 16:24:33 GMT, Daniel D. Daugherty <dcubed at openjdk.org> wrote:
>> src/hotspot/share/runtime/threadSMR.inline.hpp line 53:
>>
>>> 51: assert_not_singular();
>>> 52: assert_same_list(i);
>>> 53: return _thread_ptr != i._thread_ptr;
>>
>> Better might be to have the entire body consist of `return operator==(i);`.
>
> I think what's there is more clear. If we switch to `return operator==(i)`,
> then I think that will lead to some head scratching. Especially since it's
> making me wonder right now...
And _obviously_ I meant `return !operator==(i)`. Need to keep that all-important one-character difference...
-------------
PR: https://git.openjdk.java.net/jdk/pull/4671
More information about the hotspot-gc-dev
mailing list