Integrated: 8276093: Improve naming in closures to iterate over card sets
tschatzl at openjdk.java.net
Thu Nov 18 17:02:44 UTC 2021
On Wed, 17 Nov 2021 13:10:02 GMT, Thomas Schatzl <tschatzl at openjdk.org> wrote:
> Hi all,
> can I have reviews for this renaming change that tries to change naming for some remembered set closures to include `Closure` instead of `Iterator` in their names. Additionally I removed two or so `G1` prefixes for nested classes. Hopefully this improves the situation a bit, although it's still a mess of nested closures.
> Testing: local compilation, gha
This pull request has now been integrated.
Author: Thomas Schatzl <tschatzl at openjdk.org>
Stats: 62 lines in 5 files changed: 1 ins; 0 del; 61 mod
8276093: Improve naming in closures to iterate over card sets
Reviewed-by: sjohanss, ayang
More information about the hotspot-gc-dev