RFR: 8276047: G1: refactor G1CardSetArrayLocker
Albert Mingkun Yang
ayang at openjdk.java.net
Wed Oct 27 08:58:28 UTC 2021
Simple refactoring in `G1CardSetArrayLocker`:
1. rename fields to sth more explicit
2. drop `volatile` for thread-local variables
3. increment directly without treating `bool` as an integer
Test: hotspot_gc
-------------
Commit messages:
- cleanup
Changes: https://git.openjdk.java.net/jdk/pull/6134/files
Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=6134&range=00
Issue: https://bugs.openjdk.java.net/browse/JDK-8276047
Stats: 21 lines in 2 files changed: 3 ins; 4 del; 14 mod
Patch: https://git.openjdk.java.net/jdk/pull/6134.diff
Fetch: git fetch https://git.openjdk.java.net/jdk pull/6134/head:pull/6134
PR: https://git.openjdk.java.net/jdk/pull/6134
More information about the hotspot-gc-dev
mailing list