RFR: 8278581: Improve reference processing statistics log output

Albert Mingkun Yang ayang at openjdk.java.net
Wed Jan 12 11:18:31 UTC 2022


On Wed, 12 Jan 2022 08:49:32 GMT, Per Liden <pliden at openjdk.org> wrote:

> "enqueued" is a better name than "Processed" in this context

"enqueued" could be misleading due to its similarity with `Reference::enqueue()/ReferenceQueue` though.

> Having "dropped" seems superfluous to me.

Kim prefers having all three metrics, so I went for the current approach. (I agree there's some redundancy here.)

"Having all 3 of Discovered, Dropped (though with a better name?), and Processed would be nice since it avoids needing to calculate one from the other two."

> having "encountered" is useful to see how many there are in total.

True, but I am not sure how useful "knowing the total #refs" is. After all, only discovered-ref affects the duration of ref-processing. Ref-encountering happens along with marking, but #encountered doesn't directly affect marking phase duration.

-------------

PR: https://git.openjdk.java.net/jdk/pull/6806



More information about the hotspot-gc-dev mailing list