RFR: 8306440: Rename PSS:_num_optional_regions to _max_num_optional_regions [v3]

Thomas Schatzl tschatzl at openjdk.org
Fri Apr 21 14:21:02 UTC 2023


On Fri, 21 Apr 2023 09:23:43 GMT, Albert Mingkun Yang <ayang at openjdk.org> wrote:

>> Thomas Schatzl has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains two commits:
>> 
>>  - ayang review
>>  - Rename PSS:_num_optional_regions to _num_initial_optional_regions to emphasize that it's the initial amount of optional regions
>>    
>>    Rename the stated member to better indicate that this is the initial amount of optional
>>    region at the start of gc vs. the one for the current iteration of the evacuation.
>>    Optional.
>
> I feel `_max_num_optional_regions` better reflects its intrinsic semantic.
> 
> Inside young-gc pause, `initial` and `optional` most often refer to the dual initial-evac vs optional-evac and everything associated with them. Therefore, it can be confusing to see both words in one name.
> 
> (Ofc, this is quite subjective.)

Thanks @albertnetymk @walulyai for your reviews

-------------

PR Comment: https://git.openjdk.org/jdk/pull/13532#issuecomment-1517902262


More information about the hotspot-gc-dev mailing list