RFR: 8300653: G1EvacInfo should use common naming scheme for collection set
Thomas Schatzl
tschatzl at openjdk.org
Fri Jan 20 14:34:41 UTC 2023
On Thu, 19 Jan 2023 13:39:26 GMT, Thomas Schatzl <tschatzl at openjdk.org> wrote:
> Hi all,
>
> please review this imo trivial renaming of some identifiers containing `collectionset` to `collection_set`.
>
> Testing: local compilation
>
> Thanks,
> Thomas
We can always go back and rename as needed, but let's do that separately.
E.g. in class names like `G1CSetSomething` vs. `G1CollectionSetSomething`, the former with its four capitals one after another seems to be too cramped (particularly because after the following "et" there's another capital letter). However that may just my particular preference.
Spelling it out does not add another abbreviation (although this one is already present), making the code more approachable imo.
We have (had) various abbreviations for members (a few of them starting with "C") which also does not help too, so some additional fluff for better disambiguation seems good to me.
Anyway, enough of that rambling: Thanks for your reviews.
-------------
PR: https://git.openjdk.org/jdk/pull/12096
More information about the hotspot-gc-dev
mailing list