RFR: 8301229: Clean up SuspendibleThreadSet::_suspend_all

Kim Barrett kbarrett at openjdk.org
Sun Jan 29 00:19:15 UTC 2023


On Fri, 27 Jan 2023 14:21:21 GMT, Erik Österlund <eosterlund at openjdk.org> wrote:

> The SuspendibleThreadSet::_suspend_all variable is read and set concurrently, yet relies only on volatiles in accessors. They should use Atomic instead. Also, the _suspend_all getter is called suspend_all(), but since this function doesn't suspend anything, the name looks really confusing where it is, and there is an alias should_yield() that just calls suspend_all(), and better explains what the code does. This CR aims to remove suspend_all() and have a single getter, being should_yield (which reads better everywhere it is used), and make sure the accessors do use Atomic.

Looks good.

-------------

Marked as reviewed by kbarrett (Reviewer).

PR: https://git.openjdk.org/jdk/pull/12256


More information about the hotspot-gc-dev mailing list