RFR: 8310939: [c1] The visibility of write-volatile requires membar_volatile instead of membar

Dean Long dlong at openjdk.org
Wed Jul 19 20:39:40 UTC 2023


On Tue, 27 Jun 2023 12:46:14 GMT, SUN Guoyun <duke at openjdk.org> wrote:

> For c1 now, a volatile write case:
> 
> membar_release // LoadStore | StoreStore
> write volatile
> membar
> 
> Just like c2, here `membar` should be defined `membar_volatile` clearly, then for risc-v, ppc and loongarch can use StoreLoad for `membar_volatile` for better performance.
> 
> Testing:
> GHA testing
> jtreg tier1-3 for loongarch64

It's confusing to me to rename the post-barrier but not the pre-barrier.  Instead of changing membar_release + membar to 
membar_release + membar_volatile, something like volatile_write_pre_barrier + volatile_write_post_barrier in the shared code makes more sense to me.

-------------

PR Comment: https://git.openjdk.org/jdk/pull/14677#issuecomment-1642721198


More information about the hotspot-gc-dev mailing list