RFR: 8303883: Confusing parameter name in G1UpdateRemSetTrackingBeforeRebuild::distribute_marked_bytes

Albert Mingkun Yang ayang at openjdk.org
Thu Mar 9 12:22:24 UTC 2023


On Thu, 9 Mar 2023 11:50:09 GMT, Thomas Schatzl <tschatzl at openjdk.org> wrote:

> Hi all,
> 
>   please review this change to de-confuse (imo) a parameter in `G1UpdateRemSetTrackingBeforeRebuild::distribute_marked_bytes`.
> 
> I also replaced some `SIZE_FORMAT` in the vicinity.
> 
> Testing: local jtreg gc test, GHA
> 
> Thanks,
>   Thomas

src/hotspot/share/gc/g1/g1ConcurrentMark.cpp line 1159:

> 1157:       // humongous object spans.
> 1158:       if (hr->is_humongous()) {
> 1159:         assert(hr->is_starts_humongous() || !_cm->contains_live_object(region_idx),

I actually think `byte == 0` is more transparent here.

-------------

PR: https://git.openjdk.org/jdk/pull/12947


More information about the hotspot-gc-dev mailing list