RFR: 8319373: Serial: Refactor dirty cards scanning during Young GC [v10]

Kim Barrett kbarrett at openjdk.org
Wed Nov 22 09:25:12 UTC 2023


On Tue, 21 Nov 2023 14:17:30 GMT, Albert Mingkun Yang <ayang at openjdk.org> wrote:

>> I don't think I would have ever guessed that, which suggests it might not be an ideal naming choice.
>
> My concern regarding `cur_card` is that there is no contrasting `prev_` or `next_` in this context. The sole message I want to convey here is that we are iterating through cards. Using the conventional loop variable `i` plus `card` seems like the most natural approach, in my opinion. It is concise, so it doesn't introduce much overhead despite its frequent occurrence in the context. Therefore, I prefer the current name. By the way, the same style and convention are also employed in other methods in this PR. Additionally, similar naming conventions can be found in the already merged code of Parallel (`PSCardTable`) and G1 (`G1ScanHRForRegionClosure`).

I think "cur" is a frequently used naming convention for iteration, irrespective of there being related
"prev" or "next".  I don't like the similar naming in those other places you mention either.  Like I said,
"i" usually indicates an integral/index variable, and using it otherwise is (at least to me) confusing.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/16492#discussion_r1401740722


More information about the hotspot-gc-dev mailing list