RFR: 8330145: Serial: Refactor SerialHeap::scan_evacuated_objs

Albert Mingkun Yang ayang at openjdk.org
Thu Apr 18 08:53:00 UTC 2024


On Thu, 18 Apr 2024 08:26:25 GMT, Thomas Schatzl <tschatzl at openjdk.org> wrote:

>> That should also work; identical asm I assume.
>> 
>> (The double negation (`!` and `no_`) makes it slightly less readable, so I went for this `break` approach.)
>
> Would it be possible to rename the method then? The `break` approach is much uglier.

One can probably use `saved_mark_at_top()` in the while-condition. Why do you think using `break` is ugly here? I feel it's kind of nice that all accesses around saved-mark-word & top are right within the while-body.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/18750#discussion_r1570295613


More information about the hotspot-gc-dev mailing list