RFR: 8330145: Serial: Refactor SerialHeap::scan_evacuated_objs

Stefan Karlsson stefank at openjdk.org
Thu Apr 18 11:29:07 UTC 2024


On Thu, 18 Apr 2024 08:50:38 GMT, Albert Mingkun Yang <ayang at openjdk.org> wrote:

>> Would it be possible to rename the method then? The `break` approach is much uglier.
>
> One can probably use `saved_mark_at_top()` in the while-condition. Why do you think using `break` is ugly here? I feel it's kind of nice that all accesses around saved-mark-word & top are right within the while-body.

Maybe the break could be removed by changing the code this?:

while (young_gen()->saved_mark_word() < young_gen()->top());

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/18750#discussion_r1570350289


More information about the hotspot-gc-dev mailing list