RFR: 8334060: Implementation of Late Barrier Expansion for G1 [v5]

Roberto Castañeda Lozano rcastanedalo at openjdk.org
Fri Aug 9 11:52:35 UTC 2024


On Fri, 9 Aug 2024 11:48:17 GMT, Roberto Castañeda Lozano <rcastanedalo at openjdk.org> wrote:

>> This changeset implements JEP 475 (Late Barrier Expansion for G1), including support for the x64 and aarch64 platforms. See the [JEP description](https://openjdk.org/jeps/475) for further detail.
>> 
>> We aim to integrate this work in JDK 24. The purpose of this pull request is double-fold:
>> 
>> - to allow maintainers of the arm (32-bit), ppc, riscv, s390, and x86 (32-bit) ports to contribute a port of these platforms in time for JDK 24; and
>> - to allow reviewers to review the platform-independent, x64 and aarch64, and test changes in parallel with the porting work.
>> 
>> ## Summary of the Changes
>> 
>> ### Platform-Independent Changes (`src/hotspot/share`)
>> 
>> These consist mainly of:
>> 
>> - a complete rewrite of `G1BarrierSetC2`, to instruct C2 to expand G1 barriers late instead of early;
>> - a few minor changes to C2 itself, to support removal of redundant decompression operations and to address an OopMap construction issue triggered by this JEP's increased usage of ADL `TEMP` operands; and
>> - temporary support for porting the JEP to the remaining platforms.
>> 
>> The temporary support code (guarded by the pre-processor flag `G1_LATE_BARRIER_MIGRATION_SUPPORT`) will **not** be part of the final pull request, and hence does not need to be reviewed.
>> 
>> ### Platform-Dependent Changes (`src/hotspot/cpu`)
>> 
>> These include changes to the ADL instruction definitions and the `G1BarrierSetAssembler` class of the x64 and aarch64 platforms.
>> 
>> #### ADL Changes
>> 
>> The changeset uses ADL predicates to force C2 to implement memory accesses tagged with barrier information using G1-specific, barrier-aware instruction versions (e.g. `g1StoreP` instead of the GC-agnostic `storeP`). These new instruction versions generate machine code accordingly to the corresponding tagged barrier information, relying on the G1 barrier implementations provided by the `G1BarrierSetAssembler` class. In the aarch64 platform, the bulk of the ADL code is generated from a higher-level version using m4, to reduce redundancy.
>> 
>> #### `G1BarrierSetAssembler` Changes
>> 
>> Both platforms basically reuse the barrier implementation for the bytecode interpreter, with the different barrier tests and operations refactored into dedicated functions. Besides this, `G1BarrierSetAssembler` is extended with assembly-stub routines that implement the out-of-line, slow path of the barriers. These routines include calls from the barrier into the JVM, which require support for saving and restoring live ...
>
> Roberto Castañeda Lozano has updated the pull request incrementally with one additional commit since the last revision:
> 
>   Give barrier generation helper functions a more consistent name

Thanks for reviewing, Albert!

> ```
> g1_write_barrier_post_c2
> generate_c2_post_barrier_stub
> ```
> 
> The latter is the "next" step if slower path is taken. I wonder if it can be renamed to sth like "...write_barrier_post_c2_stub" to make it obvious that they are related.

I agree with your suggestion, but will postpone it to a follow-up task to avoid interfering with the ongoing port work (the names are dictated by the platform-independent `G1PreBarrierStubC2::emit_code()` and `G1PostBarrierStubC2::emit_code()` functions, so a name change would affect every platform).

> Both "write_barrier_pre" and "pre_write_barrier" exist. It's not obvious whether that is intended (to highlight some diff) or not.

This is accidental, as far as I can see. `write_barrier_pre` is the pre-existing name for the interpreter barrier generation functions, I would rather leave it as-is to avoid making this changeset even larger. Instead, I have renamed the helper functions `g1_pre_write_barrier()` and `g1_post_write_barrier()` to `write_barrier_pre()` and `write_barrier_post()`, for consistency (and dropped `g1_` since it is obvious from the context) in commit 1834bf4.

-------------

PR Comment: https://git.openjdk.org/jdk/pull/19746#issuecomment-2277770042


More information about the hotspot-gc-dev mailing list