RFR: 8337658: ZGC: Move soft reference handling out of the driver loop function [v2]
Stefan Karlsson
stefank at openjdk.org
Tue Aug 20 10:11:49 UTC 2024
On Tue, 20 Aug 2024 10:07:07 GMT, Stefan Karlsson <stefank at openjdk.org> wrote:
>> The ZDriver code is written to be neat and have a clear outline. The soft reference handling distracts when reading this code. I propose that we hide it a bit.
>>
>> I've also clarified in comments and names that the code is dealing with clearing of *all* references.
>
> Stefan Karlsson has updated the pull request incrementally with one additional commit since the last revision:
>
> Fix inconsistent naming
I fixed the inconsistency between `soft_reference_policy` and `soft_references_policy`.
> The two verbs use and clear are put together, which is curious at first glance. When I dive into the concrete code, I can know the clear_all is actually a adjective to describe the soft_references_policy. So I don't know whether it would confuse the newbies.
Thanks for the explanation. Yes, the intention is to read this as "uses 'clear all' 'soft reference policy'". I'm going to keep that name, unless someone manages to come up with a more spot-on name that is easy to understand.
> Another problem is whether we should use the third person singular form (use uses or use in _uses_clear_all_soft_references_policy here). I search the code in current HotSpot and both forms are used now. So I am OK with the word uses. Maybe we should unify the name rule in the future.
To me "use" sounds like a command to do something, and not a property. An alternative could be to change it to "is_using_clear_all_soft_reference_policy". Would that be better?
-------------
PR Comment: https://git.openjdk.org/jdk/pull/20418#issuecomment-2298484566
More information about the hotspot-gc-dev
mailing list