RFR: 8345732: Provide helpers for using PartialArrayState [v2]
Ivan Walulya
iwalulya at openjdk.org
Fri Dec 13 09:35:38 UTC 2024
On Fri, 13 Dec 2024 01:29:13 GMT, Kim Barrett <kbarrett at openjdk.org> wrote:
>> Please review this change that introduces two new helper classes to simplify
>> the usage of PartialArrayStates to manage splitting the processing of large
>> object arrays into parallelizable chunks. G1 and Parallel young GCs are
>> changed to use this new mechanism.
>>
>> PartialArrayTaskStats is used to collect and report statistics related to
>> array splitting. It replaces the direct implementation in PSPromotionManager,
>> and is now also used by G1 young GCs.
>>
>> PartialArraySplitter packages up most of the work involved in splitting and
>> processing tasks. It provides task allocation and release, enqueuing, chunk
>> claiming, and statistics tracking. It does this by encapsulating existing
>> objects and functionality. Using array splitting is mostly reduced to calling
>> the splitter's start function and then calling it's step function to process
>> partial states. This substantially reduces the amount of code for each client
>> to perform this work.
>>
>> Testing: mach5 tier1-5
>>
>> Manually ran some test programs with each of G1 and Parallel, with taskqueue
>> stats logging enabled, and checked that the logged statistics looked okay.
>
> Kim Barrett has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains five additional commits since the last revision:
>
> - Merge branch 'master' into pa-splitter
> - parallel uses PartialArraySplitter
> - g1 uses PartialArraySplitter
> - add PartialArraySplitter
> - add PartialArrayTaskStats
LGTM!
Minor nit:
src/hotspot/share/gc/shared/partialArraySplitter.inline.hpp line 62:
> 60: template<typename Queue>
> 61: PartialArraySplitter::Step
> 62: PartialArraySplitter::step(PartialArrayState* state, Queue* queue, bool stolen) {
Probably easier to read if we rename to `claim`, step is used as noun in many other places
-------------
Marked as reviewed by iwalulya (Reviewer).
PR Review: https://git.openjdk.org/jdk/pull/22622#pullrequestreview-2501832505
PR Review Comment: https://git.openjdk.org/jdk/pull/22622#discussion_r1883630926
More information about the hotspot-gc-dev
mailing list