RFR: 8325725: Parallel: Refactor PSParallelCompact::fill_dense_prefix_end [v2]

Albert Mingkun Yang ayang at openjdk.org
Thu Feb 29 12:08:54 UTC 2024


On Thu, 29 Feb 2024 10:51:28 GMT, Thomas Schatzl <tschatzl at openjdk.org> wrote:

>> Albert Mingkun Yang has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains one commit:
>> 
>>   pgc-end-bit
>
> src/hotspot/share/gc/parallel/psParallelCompact.cpp line 1459:
> 
>> 1457:     // Exactly one heap word gap right before dense prefix end; the filler obj
>> 1458:     // will extend to next region.
>> 1459:     const size_t obj_len = 2; // min-obj-size
> 
> It may make sense to use `CollectedHeap::min_fill_size()` for the `2` magic constants here even if there is that assert at the top of the method (and other code below assumes that). After all, the code puts in an object of `min_fill_size()`.
> Similarly I think the comment next to this line is not that useful, the important point is that the filler object that is about to be put in is of size `min_fill_size()`, not `min_obj_size()` (although they are the same).
> Then the comment can also go away because it's self-describing imo.

In this `if` block`, all literals (`2` and `1`) assumes filler-size == 2. Using an abstract min-fill-size method-call impairs readability, IMO, so I kept these magic numbers and used `min-fill-size` in the comment.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/17822#discussion_r1507471702


More information about the hotspot-gc-dev mailing list