RFR: 8234502: Merge GenCollectedHeap and SerialHeap [v11]
Albert Mingkun Yang
ayang at openjdk.org
Wed Jan 10 19:50:27 UTC 2024
On Wed, 10 Jan 2024 15:45:42 GMT, Lei Zaakjyu <duke at openjdk.org> wrote:
>> 8234502: Merge GenCollectedHeap and SerialHeap
>
> Lei Zaakjyu has updated the pull request incrementally with one additional commit since the last revision:
>
> fix
src/jdk.hotspot.agent/share/classes/sun/jvm/hotspot/utilities/PointerFinder.java line 87:
> 85: // Check if address is in the java heap.
> 86: CollectedHeap heap = VM.getVM().getUniverse().heap();
> 87: if (heap instanceof GenCollectedHeap) {
Maybe just rename this to `SerialHeap` so that this PR doesn't touch much SA code unnecessarily. (The inconsistency among different collectors can be dealt with in other PRs.)
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/16927#discussion_r1447880653
More information about the hotspot-gc-dev
mailing list