RFR: 8324649: Shenandoah: refactor implementation of free set [v4]
Kelvin Nilsen
kdnilsen at openjdk.org
Tue Jan 30 23:16:39 UTC 2024
On Sun, 28 Jan 2024 22:55:05 GMT, Y. Srinivas Ramakrishna <ysr at openjdk.org> wrote:
>> src/hotspot/share/gc/shenandoah/shenandoahFreeSet.hpp line 40:
>>
>>> 38: };
>>> 39:
>>> 40: class ShenandoahSetsOfFree {
>>
>> I wonder if "ShenandoahSetsOfFreeRegions" or "ShenandoahFreeRegionSets" is a better name.
>
> The other possibility is to think of the types defined further above as inducing a partitioning of the [free] regions on the heap, and call it `Shenandoah[Free]RegionPartition`.
>
> I place [free] in the optional bracket because you have a NotFree type, so I am not sure if the partitioning implicitly includes all regions of the heap both free and not free, depending on which the "free" might be kept or dropped.
Thanks for this guidance. I'm going with ShenandoahRegionPartition (which does include the NotFree partition).
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/17561#discussion_r1472101374
More information about the hotspot-gc-dev
mailing list