RFR: 8334060: Implementation of Late Barrier Expansion for G1

Albert Mingkun Yang ayang at openjdk.org
Wed Jun 19 08:45:17 UTC 2024


On Wed, 19 Jun 2024 08:34:25 GMT, Roberto Castañeda Lozano <rcastanedalo at openjdk.org> wrote:

>> Thanks for the suggestion, I will try it out.
>
> Is [this](https://github.com/robcasloz/jdk/compare/JDK-8334060-g1-late-barrier-expansion...robcasloz:jdk:JDK-8334060-g1-late-barrier-expansion-alberts-barriers-suggestion) what you had in mind? I don't have a strong opinion, but if you think the change improves readability I am happy to merge it.

Yes. 

Two nits: add `can_` to those two bools and unpack the final return expr, sth like:


int barriers = 0;

if (!can_remove_pre...) {
  barriers |= pre;
}
if (!can_remove_post...) {
  barriers |= post;
}

return barriers;

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/19746#discussion_r1645708369


More information about the hotspot-gc-dev mailing list