RFR: 8324649: Shenandoah: replace implementation of free set [v53]
Kelvin Nilsen
kdnilsen at openjdk.org
Mon May 6 21:09:08 UTC 2024
On Fri, 3 May 2024 15:40:57 GMT, Roman Kennke <rkennke at openjdk.org> wrote:
>> Kelvin Nilsen has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains 114 commits:
>>
>> - Merge remote-tracking branch 'origin/master' into restructure-free-set
>> - Merge branch 'openjdk:master' into master
>> - Merge branch 'openjdk:master' into master
>> - Remove unnecessary call to update_watermark
>> - Assert progress on find_next and find_prev
>> - Simplify partition_membership_name by code reuse
>> - Simplify by combining implemnetations of shrink_interval functions
>> - Fix NumPartition type
>>
>> Beautify the code by changing type of NumPartitions and adding Int and
>> UInt forms of NumPartitions.
>> - Refinements to support zero-build compiles
>> - Fix whitespace
>> - ... and 104 more: https://git.openjdk.org/jdk/compare/a863ef5d...d6e3546c
>
> src/hotspot/share/gc/shenandoah/shenandoahSimpleBitMap.cpp line 31:
>
>> 29: ShenandoahSimpleBitMap::ShenandoahSimpleBitMap(size_t num_bits) :
>> 30: _num_bits(num_bits),
>> 31: _num_words((num_bits + (BitsPerWord - 1)) / BitsPerWord),
>
> I think it would be easier to read as `_num_words(align_up(num_bits, BitsPerWord) / BitsPerWord)`
Agree that's cleaner. Thanks.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/17561#discussion_r1591556062
More information about the hotspot-gc-dev
mailing list