RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v5]
Guoxiong Li
gli at openjdk.org
Fri May 10 08:44:18 UTC 2024
On Wed, 8 May 2024 10:04:15 GMT, Albert Mingkun Yang <ayang at openjdk.org> wrote:
>> It's probably easier to read the new code directly. The two classes in `serialVMOperations` serve as entrance points to invoke young/full GCs. Some previously hidden decisions are made more obvious, e.g. if a young-gc fails (or will probablly fail), fallback to full-gc.
>>
>> Additionally, `StatRecord` is removed, because this kind of info-aggregation should be done outsite VM (by third-party tool).
>>
>> Test: tier1-6
>
> Albert Mingkun Yang has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains five commits:
>
> - Merge branch 'master' into s1-do-collect
> - merge
> - review
> - Merge branch 'master' into s1-do-collect
> - s1-do-collect
Looks good. One suggestion, but not necessary.
src/hotspot/share/gc/serial/serialHeap.cpp line 656:
> 654: do_full_collection_no_gc_locker(clear_soft_refs);
> 655: }
> 656:
Maybe the method `do_young_gc` can be renamed to `do_young_collection` or `do_young_collection_no_gc_locker` which is consistent with `do_full_collection` or `do_full_collection_no_gc_locker`.
-------------
Marked as reviewed by gli (Committer).
PR Review: https://git.openjdk.org/jdk/pull/19056#pullrequestreview-2049609145
PR Review Comment: https://git.openjdk.org/jdk/pull/19056#discussion_r1596463754
More information about the hotspot-gc-dev
mailing list