RFR: 8356716: ZGC: Cleanup Uncommit Logic [v2]

Axel Boldt-Christmas aboldtch at openjdk.org
Wed May 14 06:34:31 UTC 2025


> [JDK-8350441](https://bugs.openjdk.org/browse/JDK-8350441) required changing the way ZGC handle memory uncommitting (returning physical memory to the OS). Previously ZGC tracked how recently used memory was on a ZPage level. [JDK-8350441](https://bugs.openjdk.org/browse/JDK-8350441) did away with the ZPage abstraction for unused memory. But because of this ZGC does not have a convenient way of tracking the usage of a specific memory range. Instead [JDK-8350441](https://bugs.openjdk.org/browse/JDK-8350441) opted to keep a watermark in the cache unused mapped memory, to keep track of the amount of memory that was not used within the last ZUncommitDelay, and use this when deciding how much to uncommit.
> 
> Because this measurement is not as granular as previously, and because uncommitting memory is something we want to do conservatively, as a response to low memory utilization, [JDK-8350441](https://bugs.openjdk.org/browse/JDK-8350441) was written with the intent to spread out the uncommitting over some time interval.
> 
> The actual implementation in [JDK-8350441](https://bugs.openjdk.org/browse/JDK-8350441) has a few issues which this RFE tries to address:
>   * Missing wait, the uncommitting is not actually spread out, but happens all at once.
>   * Reactivity, if the process starts using memory that was below the previous watermark, uncommitting should stop.
>   * Structure, the current implementation has a lot of different dependencies and has state spread out over multiple classes. Refactor to keep the logic contained to the ZUncommitter, and provide better named facilitating functions on the ZPartition and ZMappedCache. And make the lifecycle of ZUncommitter more explicit.
>   * Events, overhaul the JFR uncommit events to be sent (and track the time for) a chunk of uncommits without any waits.
> 
> An alternative discussed has been to do uncommitting based on GC triggers rather than a periodically. So rather than using ZUncommitDelay, we could have our proactive GCs actually trigger and track uncommitting. This might be a future RFE, but it was not attempted here as it would change user facing APIs. [JDK-8329758](https://bugs.openjdk.org/browse/JDK-8329758) will more than likely overhaul the uncommit triggers as well, and the whole concept of ZUncommitDelay and having to tune how to uncommit will go away.

Axel Boldt-Christmas has updated the pull request incrementally with seven additional commits since the last revision:

 - Wrong too
 - Less archaic spelling of complete
 - Cleanup and simplify
 - Move all uncommit logic to zUncommitter
 - Log time spent uncommitting
 - Split reset_uncommit_cycle and add headroom
 - Rename _min_last_uncommit_cycle to _min_size_watermark

-------------

Changes:
  - all: https://git.openjdk.org/jdk/pull/25198/files
  - new: https://git.openjdk.org/jdk/pull/25198/files/82a87d8d..96ce895f

Webrevs:
 - full: https://webrevs.openjdk.org/?repo=jdk&pr=25198&range=01
 - incr: https://webrevs.openjdk.org/?repo=jdk&pr=25198&range=00-01

  Stats: 265 lines in 7 files changed: 117 ins; 110 del; 38 mod
  Patch: https://git.openjdk.org/jdk/pull/25198.diff
  Fetch: git fetch https://git.openjdk.org/jdk.git pull/25198/head:pull/25198

PR: https://git.openjdk.org/jdk/pull/25198


More information about the hotspot-gc-dev mailing list