<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Hi Ramki,<br>
<br>
Thanks for looking at the code changes and for the suggestions.<br>
<br>
Extending the os API is a good idea. Not sure about the name though -
how about: javaMonotonicTimeMillis? Also I believe os_solaris.cpp
already has an internal monotonic version of javaTimeMillis() so there
are alternatives to using javaTimeNanos() in the implementation.<br>
<br>
Thanks for the heads up about the other CR. I'll check.<br>
<br>
Thanks,<br>
<br>
JohnC<br>
<br>
On 12/11/11 01:32, Srinivas Ramakrishna wrote:
<blockquote
cite="mid:CABzyjy=wnZedMebem8c7_kyWuhkUz1z7O7zFQPRzoCmvMLMFXw@mail.gmail.com"
type="cite">Hi John -- Looks fine. Two minor comments:<br>
<br>
(1) by defining an os::javaTimeNanosInMillis() you may be able to
consolidate the divide by NANOS_IN_MILLISEC to one place instead of it
appearing at each use.<br>
(2) you might consolidate the commentary about monotonicity into
os::javaTimeNanosInMillis(), then at each client simly say "Protect
against possible nonmonotonicity"<br>
<br>
That will reduce the number of repeated lines while still providing all
of the commentary in all the relevant places. (By the way, you might
want to<br>
check if there;s another CR with the same content which might be closed
as a dup of this... just a very vague recollection.)<br>
<br>
reviewed.<br>
-- ramki (opendjk: ysr)<br>
<br>
<div class="gmail_quote">On Fri, Dec 9, 2011 at 11:30 AM, John
Cuthbertson <span dir="ltr"><<a moz-do-not-send="true"
href="mailto:john.cuthbertson@oracle.com">john.cuthbertson@oracle.com</a>></span>
wrote:<br>
<blockquote class="gmail_quote"
style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">Hi
Everyone,<br>
<br>
I have updated the comments based upon feedback from David Holmes. A
new webrev can be found at: <a moz-do-not-send="true"
href="http://cr.openjdk.java.net/%7Ejohnc/7117303/webrev.1/"
target="_blank">http://cr.openjdk.java.net/~johnc/7117303/webrev.1/</a><br>
<br>
Thanks,<br>
<br>
JohnC
<div class="HOEnZb">
<div class="h5"><br>
<br>
On 12/7/2011 9:59 AM, John Cuthbertson wrote:<br>
<blockquote class="gmail_quote"
style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Hi Everyone,<br>
<br>
Can I have a couple of volunteers review the changes for this CR? The
webrev can be found at: <a moz-do-not-send="true"
href="http://cr.openjdk.java.net/%7Ejohnc/7117303/webrev.0/"
target="_blank">http://cr.openjdk.java.net/~johnc/7117303/webrev.0/</a>.<br>
<br>
Summary:<br>
I replaced the calls to os::javaTimeMillis() in the GC where we expect
monotonicity with calls os::javaTimeNanos(), converting the result to
milliseconds. os::javaTimeNanos(), at least on some configurations,
does guarantee monotonicity and so is a better alternative. The changes
in the os_<*> files are to make use of the named conversion
constants I added/moved to globalDefinitions.hpp - we seemed to have
multiple names for the same two constants.<br>
<br>
Testing: GC test suite on solaris and Linux, NSK tests on solaris, and
jprt.<br>
<br>
Thanks,<br>
<br>
JohnC<br>
</blockquote>
</div>
</div>
</blockquote>
</div>
<br>
</blockquote>
<br>
</body>
</html>