<html>
  <head>
    <meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    <div class="moz-cite-prefix"><br>
      Hi Thomas,<br>
      <br>
      In arguments.cpp you check for
      <meta http-equiv="content-type" content="text/html; charset=UTF-8">
      MarkSweepAlwaysCompactCount == 0 and in that case silently set
      <meta http-equiv="content-type" content="text/html; charset=UTF-8">
      MarkSweepAlwaysCompactCount = 1. I think I would prefer not to
      reset it and let there be an error message when we hit
      "verify_min_value(MarkSweepAlwaysCompactCount, 1,
      "MarkSweepAlwaysCompactCount");" further down. Otherwise people
      won't know that they have made a mistake on the command line if
      they run with -XX:MarkSweepAlwaysCompactCount=0.<br>
      <br>
      One minor nit:<br>
      <br>
      In psMarkSweep.cpp you updated one line to be:<br>
      <br>
      unsigned int count = (maximum_heap_compaction)? 1 :
      MarkSweepAlwaysCompactCount;<br>
      <br>
      I don't think the parenthesis increase readability here, but it
      would help with a space before the ?. Also, I am more used to
      seeing uint instead of unsigned int, but HotSpot has a lot of
      occurrences of both variants, so I leave it up to you to choose.
      So, to summarize I would prefer:<br>
      <br>
      uint count = maximum_heap_compaction ? 1 :
      MarkSweepAlwaysCompactCount;<br>
      <meta http-equiv="content-type" content="text/html; charset=UTF-8">
      <br>
      Otherwise looks good!<br>
      Bengt<br>
      <br>
      On 5/13/13 9:42 PM, Thomas Schatzl wrote:<br>
    </div>
    <blockquote cite="mid:1368474125.2659.48.camel@cirrus" type="cite">
      <pre wrap="">Hi all,

  after an internal review, please have a look at the current version.

The difference to the previous is
- change the type of MarkSweepAlwaysCompactCount from intx to uintx,
with related changes.

Difference to the first version
- minimum value for HeapSizePerGCThread is os::vm_page_size() (suggested
by Jon M.)

Bugs.sun
<a class="moz-txt-link-freetext" href="http://bugs.sun.com/view_bug.do?bug_id=6843347">http://bugs.sun.com/view_bug.do?bug_id=6843347</a>

JBS:
<a class="moz-txt-link-freetext" href="https://jbs.oracle.com/bugs/browse/JDK-6843347">https://jbs.oracle.com/bugs/browse/JDK-6843347</a>

Webrev:
<a class="moz-txt-link-freetext" href="http://cr.openjdk.java.net/~tschatzl/6843347/webrev.2/">http://cr.openjdk.java.net/~tschatzl/6843347/webrev.2/</a>

Testing:
jprt

Thanks,
  Thomas

</pre>
    </blockquote>
    <br>
  </body>
</html>