<html>
<head>
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
</head>
<body bgcolor="#FFFFFF" text="#000000">
<div class="moz-cite-prefix"><br>
Tao,<br>
<br>
On 6/3/13 9:16 PM, Tao Mao wrote:<br>
</div>
<blockquote cite="mid:51ACEBA1.40302@oracle.com" type="cite">
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
new webrev:<br>
<a moz-do-not-send="true" class="moz-txt-link-freetext"
href="http://cr.openjdk.java.net/%7Etamao/6976350/webrev.07/">http://cr.openjdk.java.net/~tamao/6976350/webrev.07/</a><br>
</blockquote>
<br>
This looks good to me. Thanks for working through all of these
iterations!<br>
<br>
There are superfluous spaces on these lines before
_priority_buffer[0]:<br>
<br>
<meta http-equiv="content-type" content="text/html; charset=UTF-8">
1803 G1ParGCAllocBuffer* retired_and_set = _priority_buffer[0];<br>
1812 G1ParGCAllocBuffer* retired_and_set = _priority_buffer[0];<br>
<br>
Other than that it looks good!<br>
<br>
<blockquote cite="mid:51ACEBA1.40302@oracle.com" type="cite"> <br>
Please see inline.<br>
</blockquote>
<br>
Thanks for the detailed description about retiring alloc buffers. It
was very helpful.<br>
<br>
Bengt<br>
<br>
<blockquote cite="mid:51ACEBA1.40302@oracle.com" type="cite"> <br>
Thanks.<br>
Tao<br>
<br>
On 6/3/13 1:16 AM, Bengt Rutisson wrote:
<blockquote cite="mid:51AC50F3.3000308@oracle.com" type="cite">
<meta content="text/html; charset=UTF-8"
http-equiv="Content-Type">
<div class="moz-cite-prefix"><br>
Hi Tao,<br>
<br>
On 6/2/13 6:56 AM, Tao Mao wrote:<br>
</div>
<blockquote cite="mid:51AAD064.8030600@oracle.com" type="cite">
<meta content="text/html; charset=UTF-8"
http-equiv="Content-Type">
The new webrev is updated.<br>
<a moz-do-not-send="true" class="moz-txt-link-freetext"
href="http://cr.openjdk.java.net/%7Etamao/6976350/webrev.06/">http://cr.openjdk.java.net/~tamao/6976350/webrev.06/</a><br>
</blockquote>
<br>
Thanks for fixing this. I think it looks better. Still have some
comments:<br>
<br>
<br>
Line 78, int const GCAllocPriorityMax = 2;<br>
<br>
I would prefer that this was a "private static const int" inside
G1ParGCAllocBufferContainer. You could call it _priority_max to
avoid the assignment in the constructor.<br>
</blockquote>
Done.<br>
<br>
<blockquote cite="mid:51AC50F3.3000308@oracle.com" type="cite"> <br>
<br>
I think the name select_retired_buf() is a bit confusing. The
way it is used I think the code would be more readable if we
just inlined 0 in the code.<br>
</blockquote>
Inlining done.<br>
<br>
<blockquote cite="mid:51AC50F3.3000308@oracle.com" type="cite"> <br>
<br>
In G1ParScanThreadState::allocate_slow() I think we might miss
retiring the alloc buffers, right?<br>
<br>
We now call retire_and_set_buf() after we have we have tried the
allcoation. If the allocation fails I think we have to retired
both alloc buffers since both of them may have been allocated
into.<br>
</blockquote>
The current implementation is right. <br>
<br>
(1) Even if the code reaches the point where it need to allocate a
new buffer and fails, the old buffer is still usable. There's no
reason we should retire it entirely.<br>
<br>
In addition, I designed to keep the buffer when the allocation
fails so that the code doesn't need additional checkings in order
to make sure the buffer is still valid, when trying to allocate a
new object and to retire it per se. <br>
<br>
In fact, the current implementation simplifies the logic of object
allocation in the buffer and retiring buffers if you get it.<br>
<br>
(2) Please check out the function retire_alloc_buffers(). It
guards the clearing of all buffers in the end of copying phase, so
we don't have to worry about that part.<br>
<br>
(3) A subtle benefit to mention: I still keep the buffer when the
attempted allocation fails such way that we hope that the buffer
may be allocated again to contain a new "smaller" object. It can
happen to improve heap efficiency.<br>
<br>
<blockquote cite="mid:51AC50F3.3000308@oracle.com" type="cite"> <br>
I also think the name retire_and_set_buf() indicates that this
method does too much. I would prefer to have two different
methods. One retire_current_buf() that retires the current alloc
buffer and probably also shifts the buffers (what
adjust_priority_order() does now) and one that sets up a new
buffer.<br>
</blockquote>
I think it's a single operation and can't be separated. If we
separated this function, we would end up with exposing unnecessary
details to the caller. Also, the order of retire(), set_buf(),
set_word_size() and adjust_priority_order() matters. I don't want
to the caller to handle this rather than handle the ordering issue
in class G1ParGCAllocBufferContainer.<br>
<br>
<blockquote cite="mid:51AC50F3.3000308@oracle.com" type="cite"> <br>
This will probably also be useful if we need to only retire
buffers in the allocation failure case I described above. <br>
</blockquote>
As I mentioned above, retiring buffers upon the allocation failure
would introduce additional complexity to handling the buffer usage
and, even, retiring process itself. Please also refer to the last
third comments above.<br>
<br>
<blockquote cite="mid:51AC50F3.3000308@oracle.com" type="cite"> <br>
Thanks,<br>
Bengt<br>
<br>
<blockquote cite="mid:51AAD064.8030600@oracle.com" type="cite">
<br>
Thanks.<br>
Tao<br>
<br>
On 5/30/13 10:56 PM, Bengt Rutisson wrote:
<blockquote cite="mid:51A83B7E.9060808@oracle.com" type="cite">
<meta content="text/html; charset=UTF-8"
http-equiv="Content-Type">
<div class="moz-cite-prefix"><br>
Hi again,<br>
<br>
Just realized that I did this review a bit too early in
the morning...before the morning coffee... One correction
below.<br>
<br>
On 5/31/13 7:44 AM, Bengt Rutisson wrote:<br>
</div>
<blockquote cite="mid:51A838C1.6070100@oracle.com"
type="cite">
<meta content="text/html; charset=UTF-8"
http-equiv="Content-Type">
<div class="moz-cite-prefix"><br>
<br>
Hi Tao,<br>
<br>
Comments inline,<br>
<br>
On 5/31/13 3:26 AM, Tao Mao wrote:<br>
</div>
<blockquote cite="mid:51A7FC3A.4030601@oracle.com"
type="cite">
<meta content="text/html; charset=UTF-8"
http-equiv="Content-Type">
Please see inline.<br>
<br>
Thanks.<br>
Tao<br>
<br>
On 5/30/13 5:53 AM, Bengt Rutisson wrote:
<blockquote cite="mid:51A74BBC.7070003@oracle.com"
type="cite">
<meta content="text/html; charset=UTF-8"
http-equiv="Content-Type">
<div class="moz-cite-prefix"><br>
Hi Tao,<br>
<br>
I think the code is a little bit confused about
whether G1MultiParGCAllocBuffer can handle an
arbitary number of AllocPriorites or just 2. All the
for loops indicate that we think we might want to
change from 2 to a larger number in the future. But
the naming of a method like
words_remaining_in_retired() indicate that there can
only be one retired region. With the current
implementation I think words_remaining_in_retired()
should be called something like
words_remaining_in_priority0_buffer(). <br>
</div>
</blockquote>
Done.<br>
changed to words_remaining_in_priority1_buffer()<br>
</blockquote>
<br>
Hm. Isn't this a bug? I think you want the method to be
called
<meta http-equiv="content-type" content="text/html;
charset=UTF-8">
words_remaining_in_priority0_buffer() and return the
remaining words in the priority0 buffer. You call the
method before you do
<meta http-equiv="content-type" content="text/html;
charset=UTF-8">
alloc_buf->retire_and_set_buf(), so the priority1
buffer is probably not the one you are interested in.<br>
</blockquote>
<br>
My bad. I thought the priorities were zero indexed, but
because of your enum they are one indexed. So,
words_remaining_in_priority1_buffer() is correct here.<br>
<br>
Bengt<br>
<br>
<blockquote cite="mid:51A838C1.6070100@oracle.com"
type="cite"> <br>
<blockquote cite="mid:51A7FC3A.4030601@oracle.com"
type="cite">
<blockquote cite="mid:51A74BBC.7070003@oracle.com"
type="cite">
<div class="moz-cite-prefix"> <br>
I think it would be good to make this code truly
general with respect to the number of priorities. We
can then use 2 as default, but make sure that the
code works with more priorities. To do that I think
we should remove the enum GCAllocPriority and
instead have a field in G1MultiParGCAllocBuffer that
contains the maximum number of priorities. I think
that will make the code more general and easier to
read. The for loops would look like:<br>
<br>
for (int pr = 0; pr < _max_priorities; ++pr)
{<br>
// do stuff<br>
}<br>
</div>
</blockquote>
It's more like code style issue. In fact, it was done
this way according to the Jon's earlier suggestion.
Second, if we want to change #buffer to 3 (it wont give
more benefits to define more than that number), we only
need to add one more enum value, i.e. GCAllocPriority3.<br>
</blockquote>
<br>
Let me clarify a bit why I don't like the GCAllocPriority
enum. There is really no reason to use an enum here. You
are just making code complicated without adding any
semantics. You always want to use 0-max and the order is
important. This is exactly what you get from an normal
int.<br>
<br>
The enum
<meta http-equiv="content-type" content="text/html;
charset=UTF-8">
GCAllocPurpose is different since there is no natural
order between GCAllocForTenured and
<meta http-equiv="content-type" content="text/html;
charset=UTF-8">
GCAllocForSurvived. Thus, an enum makes sense there.<br>
<br>
So, please remove the GCAllocPriority enum.<br>
<br>
<blockquote cite="mid:51A7FC3A.4030601@oracle.com"
type="cite">
<blockquote cite="mid:51A74BBC.7070003@oracle.com"
type="cite">
<div class="moz-cite-prefix"> <br>
I find the name G1MultiParGCAllocBuffer confusing
since it is not inheriting G1ParGCAllocBuffer. Maybe
G1AllocBufferContainer or something like that would
make more sense? <br>
</div>
</blockquote>
Done. <br>
Changed to G1ParGCAllocBufferContainer
<blockquote cite="mid:51A74BBC.7070003@oracle.com"
type="cite">
<div class="moz-cite-prefix"> <br>
I don't understand why you added initialization
values to
<meta http-equiv="content-type" content="text/html;
charset=UTF-8">
GCAllocPurpose. You are only using the values that
are default in C++ anyway: 0, 1, 2. At least if you
avoid adding the
<meta http-equiv="content-type" content="text/html;
charset=UTF-8">
GCAllocPurposeStart value. I think it was more
readable before your change. (The same argument
holds for GCAllocPriority, but I prefer to remove
that enum all together as I described above.)<br>
</div>
</blockquote>
See above.<br>
</blockquote>
<br>
This is not the same issue as above. What I'm saying is
that your changes to GCAllocPurpose made it less readable
without adding any extra semantics. Please revert to this
change. <br>
<br>
<blockquote cite="mid:51A7FC3A.4030601@oracle.com"
type="cite">
<blockquote cite="mid:51A74BBC.7070003@oracle.com"
type="cite">
<div class="moz-cite-prefix"> <br>
Have you considered moving the _retired field from
G1ParGCAllocBuffer to ParGCAllocBuffer instead of
making the retire() method virtual? (I do think your
change to virtual is needed in the current code, so
good catch! But I think it might make sense to have
the logic of G1ParGCAllocBuffer::retire() in
ParGCAllocBuffer::retire() instead.)<br>
</div>
</blockquote>
In G1ParGCAllocBuffer, we need the field _retired to
handle buffer allocation failure. This is handled
differently for other collectors. For example,
ParScanThreadState::alloc_in_to_space_slow in ParNew.
Thus, moving the _retired field up to its super class
will involve additional efforts. This is supposed to be
investigated in another CR JDK-7127700.<br>
</blockquote>
<br>
OK. Good.<br>
<br>
Thanks,<br>
Bengt<br>
<br>
<blockquote cite="mid:51A7FC3A.4030601@oracle.com"
type="cite">
<blockquote cite="mid:51A74BBC.7070003@oracle.com"
type="cite">
<div class="moz-cite-prefix"> <br>
A couple of minor things:<br>
<br>
<meta http-equiv="content-type" content="text/html;
charset=UTF-8">
1800 if (finish_undo != true)
ShouldNotReachHere();<br>
<br>
should be:<br>
<br>
1800 if (!finish_undo) ShouldNotReachHere();<br>
</div>
</blockquote>
Done.<br>
<blockquote cite="mid:51A74BBC.7070003@oracle.com"
type="cite">
<div class="moz-cite-prefix"> <br>
Please add spaces before and after "=" here:<br>
1804 size_t result=0;<br>
</div>
</blockquote>
Done.<br>
<blockquote cite="mid:51A74BBC.7070003@oracle.com"
type="cite">
<div class="moz-cite-prefix"> <br>
There are two spaces after "=" here:<br>
1812 G1ParGCAllocBuffer* retired =
_priority_buffer[GCAllocPriority1];<br>
</div>
</blockquote>
Done.<br>
<blockquote cite="mid:51A74BBC.7070003@oracle.com"
type="cite">
<div class="moz-cite-prefix"> <br>
Also, in g1CollectedHeap.hpp you have updated the
copyright year but not in parGCAllocBuffer.hpp. As
you know we in the GC team have agreed not to update
the copyright year. If you absolutely want to do it
I think you should do it the same way in all files.<br>
</div>
</blockquote>
Done.<br>
<blockquote cite="mid:51A74BBC.7070003@oracle.com"
type="cite">
<div class="moz-cite-prefix"> <br>
Thanks,<br>
Bengt<br>
<br>
On 5/24/13 1:31 AM, Tao Mao wrote:<br>
</div>
<blockquote cite="mid:519EA6EA.1080308@oracle.com"
type="cite">Can I have a couple of reviewers please?
<br>
<br>
Thank you. <br>
Tao <br>
<br>
On 5/20/13 5:11 PM, Tao Mao wrote: <br>
<blockquote type="cite">Hi all, <br>
<br>
a new webrev <br>
<a moz-do-not-send="true"
class="moz-txt-link-freetext"
href="http://cr.openjdk.java.net/%7Etamao/6976350/webrev.04/">http://cr.openjdk.java.net/~tamao/6976350/webrev.04/</a>
<br>
<br>
diff: <br>
(1) John Cuthbertson and I figured out the way to
handle "retire an old buffer, allocate and set a
new one" and it can possibly make the usage of
allocation buffer a little more efficient. <br>
(2) Make the assertion as John suggested and
provide some harness (i.e. making retire() a
virtual function) to cope with it. <br>
<br>
Thanks. <br>
Tao <br>
<br>
On 5/15/13 10:58 PM, John Cuthbertson wrote: <br>
<blockquote type="cite">Hi Tao, <br>
<br>
This looks excellent. One minor question: does
it make sense to assert that each buffer has
been retired? It might save a missed call to
PSS::retire_alloc_buffers. I'll leave the
decision to you. Ship it. <br>
<br>
JohnC <br>
<br>
<br>
On 5/14/2013 3:06 PM, Tao Mao wrote: <br>
<blockquote type="cite">To the open list: <br>
<br>
new webrev: <br>
<a moz-do-not-send="true"
class="moz-txt-link-freetext"
href="http://cr.openjdk.java.net/%7Etamao/6976350/webrev.03/">http://cr.openjdk.java.net/~tamao/6976350/webrev.03/</a>
<br>
<br>
I took suggestion from many reviewers into
consideration and came up with the current
cleaner solution. <br>
<br>
Thank you. <br>
Tao <br>
<br>
<br>
On 5/14/13 2:26 PM, Jon Masamitsu wrote: <br>
<blockquote type="cite">What's the status of
this review? <br>
<br>
The last mail I could find in my mail boxes
was a comment <br>
from Thomas. <br>
<br>
Jon <br>
<br>
On 1/28/13 12:21 PM, Tao Mao wrote: <br>
<blockquote type="cite">6976350 G1: deal
with fragmentation while copying objects
during GC <br>
<a moz-do-not-send="true"
class="moz-txt-link-freetext"
href="https://jbs.oracle.com/bugs/browse/JDK-6976350">https://jbs.oracle.com/bugs/browse/JDK-6976350</a>
<br>
<br>
webrev: <br>
<a moz-do-not-send="true"
class="moz-txt-link-freetext"
href="http://cr.openjdk.java.net/%7Etamao/6976350/webrev.00/">http://cr.openjdk.java.net/~tamao/6976350/webrev.00/</a>
<br>
<br>
changeset: <br>
Basically, we want to reuse more of
par-allocation buffers instead of retiring
it immediately when it encounters an
object larger than its remaining part. <br>
<br>
(1) instead of previously using one
allocation buffer per GC purpose, we use
N(=2) buffers per GC purpose and modify
the corresponding code. The changeset
would easily scale up to whatever N
(though Tony Printezis suggests 2, or 3
may be good enough) <br>
<br>
*(2) Two places of cleanup:
allocate_during_gc_slow() is removed due
to its never being called. <br>
access modifier (public) before
trim_queue() is redundant. <br>
<br>
<br>
</blockquote>
<br>
</blockquote>
</blockquote>
<br>
</blockquote>
</blockquote>
</blockquote>
<br>
</blockquote>
</blockquote>
<br>
</blockquote>
<br>
</blockquote>
</blockquote>
<br>
</blockquote>
</blockquote>
<br>
</body>
</html>