<html>
<head>
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
</head>
<body text="#000000" bgcolor="#FFFFFF">
Thomas,<br>
<br>
Change looks correct.<br>
<br>
Would you consider "contains_or_replace()" as a better name for<br>
"contains_and_update()"?<br>
<br>
Did you consider dropping the "_from_card" from the<br>
variable names<br>
<br>
<meta http-equiv="content-type" content="text/html; charset=UTF-8">
<pre><span class="new"> 53 static int** _from_card_cache;</span>
<span class="new"> 54 static uint _from_card_cache_max_regions;</span>
<span class="new"> 55 static size_t _from_card_cache_mem_size;</span></pre>
<br>
You dropped the "_from_card_cache" from some names.<br>
"init_from_card_cache" became "initialize" for example.<br>
<br>
That's all. Small points so I'm fine with whatever you decide.<br>
<br>
Jon<br>
<br>
<br>
<div class="moz-cite-prefix">On 3/3/14 3:49 AM, Thomas Schatzl
wrote:<br>
</div>
<blockquote cite="mid:1393847389.2713.19.camel@cirrus" type="cite">
<pre wrap="">Hi all,
can I get reviews for the following small change? It extracts the from
card cache previously embedded into the OtherRegionsTable into a
separate class, named FromCardCache.
This cleans up the remembered set somewhat.
While looking through the code I found that the remembered set code
still using int's for thread id's. I did not clean that up here, created
a new CR instead (<a class="moz-txt-link-freetext" href="https://bugs.openjdk.java.net/browse/JDK-8036116">https://bugs.openjdk.java.net/browse/JDK-8036116</a>)
since that change would ripple through to quite a few places.
Webrev:
<a class="moz-txt-link-freetext" href="http://cr.openjdk.java.net/~tschatzl/8034868/webrev/">http://cr.openjdk.java.net/~tschatzl/8034868/webrev/</a>
CR:
<a class="moz-txt-link-freetext" href="https://bugs.openjdk.java.net/browse/JDK-8034868">https://bugs.openjdk.java.net/browse/JDK-8034868</a>
Testing:
JPRT
Thanks,
Thomas
</pre>
</blockquote>
<br>
</body>
</html>