<div dir="ltr">If we are to put a wrapper around, why not just go with the original change?<div>I don't see adding a single field on a nearly singleton class is a bad thing.</div><div>The changes are well wrapped inside par_promote.</div><div>It is the fast path of the promotion, so I think it is more readable.</div><div>We don't need a long explanation to the code reader why we are allowing the data-race.</div><div><br></div></div><div class="gmail_extra"><br><div class="gmail_quote">On Thu, Nov 20, 2014 at 2:12 PM, Kim Barrett <span dir="ltr"><<a href="mailto:kim.barrett@oracle.com" target="_blank">kim.barrett@oracle.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div class="HOEnZb"><div class="h5">On Nov 19, 2014, at 12:13 PM, Jungwoo Ha <<a href="mailto:jwha@google.com">jwha@google.com</a>> wrote:<br>
><br>
> <a href="http://cr.openjdk.java.net/~rasbold/8061259/webrev.06/" target="_blank">http://cr.openjdk.java.net/~rasbold/8061259/webrev.06/</a><br>
><br>
> PTAL.<br>
><br>
> On Mon, Nov 17, 2014 at 7:57 AM, Kim Barrett <<a href="mailto:kim.barrett@oracle.com">kim.barrett@oracle.com</a>> wrote:<br>
> On Nov 17, 2014, at 5:11 AM, Bengt Rutisson <<a href="mailto:bengt.rutisson@oracle.com">bengt.rutisson@oracle.com</a>> wrote:<br>
> ><br>
> >> I think this does leave open the possibility of moving the<br>
> >> _promotion_failed flag check earlier in copy_to_survivor_space_XXX(),<br>
> >> […]<br>
> >><br>
> >> I'm not sure it would be overall beneficial though, […]<br>
> ><br>
> > Yes, there is probably room for more improvement here. I think adding the check in the copy_to_survivor_space_XXX_undo() methods is a clear improvement in many cases. So, doing that as a first step is a good start. We can consider moving it earlier as a future enhancement.<br>
><br>
> Agreed.<br>
<br>
</div></div>Mostly looks good.  A couple of nits:<br>
<br>
------------------------------------------------------------------------------<br>
src/share/vm/gc_implementation/parNew/parNewGeneration.cpp<br>
1199     // We can skip par_promote if promotion has been failed already.<br>
<br>
"... promotion has been failed already."<br>
=><br>
"... promotion has already failed."<br>
<br>
There is similar awkward grammar in the comment on the other call, but<br>
see below.<br>
<br>
------------------------------------------------------------------------------<br>
src/share/vm/gc_implementation/parNew/parNewGeneration.cpp<br>
1199     // We can skip par_promote if promotion has been failed already.<br>
1200     // Checking _promotion_failed can be racy, but the worse case is going<br>
1201     // through the slow path of calling par_promote, which will still correctly<br>
1202     // handle the promotion failure.<br>
<br>
1323     // Skip this step if promotion has already been failed.<br>
<br>
I dislike these two very different comments for the same thing.  On<br>
the other hand, I dislike duplication of information.  And a reference<br>
to the earlier comment from the later one can also become stale.<br>
<br>
Maybe add a (private) helper function that is a wrapper around the<br>
call to par_promote, with the flag test and associated comment in the<br>
wrapper?  [Though this would become obsolete if we later decide we can<br>
move the flag test earlier.] Or just duplicate the more informative<br>
comment (ick!).<br>
<br>
Bengt, what do you think?<br>
<br>
</blockquote></div><br></div>