<html>
<head>
<meta http-equiv="content-type" content="text/html; charset=utf-8">
</head>
<body bgcolor="#FFFFFF" text="#000000">
Hi<br>
<blockquote type="cite">
<pre>But JDK-8019361 looks like a wrong number. It must be JDK-8051984, I think.</pre>
</blockquote>
<br>
I'm wrongly got reason of ignore bug for RFR. Thanks, Dima.<br>
<br>
webrev:<br>
<a class="moz-txt-link-freetext" href="http://cr.openjdk.java.net/~azakharov/8051984/webrev/">http://cr.openjdk.java.net/~azakharov/8051984/webrev/</a><i><br>
<br>
</i>bug:<br>
<a class="moz-txt-link-freetext" href="https://bugs.openjdk.java.net/browse/JDK-8051984">https://bugs.openjdk.java.net/browse/JDK-8051984</a><br>
<br>
<pre><blockquote type="cite"><pre>If so, what about other sources listed in the description:
./test/gc/arguments/TestParallelHeapSizeFlags.java
./test/gc/arguments/TestUseCompressedOopsErgo.java
./test/gc/g1/TestHumongousShrinkHeap.java</pre></blockquote></pre>
Its already fixed either by removing @ignore either by inserting
@requires<br>
<i><br>
</i>
<blockquote type="cite">
<pre>Why did you change the static import of
com.oracle.java.testlibrary.Asserts? Seems unrelated to the @ignore
change and I don't think there is a reason for it either. We use static
import of the asserts a lot in our test code.
Thanks,
Bengt
><i>
</i>><i> Thanks.</i></pre>
</blockquote>
<br>
There is nothing especial in import static here, itsĀ only serves to
reduce Asserts package names in code, but it also leads to less
readability and question like "what assertLessThan comes from?".<br>
Asserts.assertLessThan is better - it doesn't junk global namespace.
In only this case - its only code style question. If you have any
other conserns about this, please tell me.<br>
<br>
<br>
Thanks.<br>
<br>
<br>
<br>
</body>
</html>