<html>
  <head>
    <meta content="text/html; charset=utf-8" http-equiv="Content-Type">
  </head>
  <body text="#000000" bgcolor="#FFFFFF">
    On 2015-04-30 09:00, Jon Masamitsu wrote:<br>
    <blockquote cite="mid:5541D310.2050800@oracle.com" type="cite">
      <meta content="text/html; charset=utf-8" http-equiv="Content-Type">
      <br>
      <br>
      <div class="moz-cite-prefix">On 4/29/2015 11:09 PM, Jungwoo Ha
        wrote:<br>
      </div>
      <blockquote
cite="mid:CA+n_jhjPN7KouhhDApc5miZkBGZ3oDwFSYnp0HLbYooMpb4BGg@mail.gmail.com"
        type="cite">
        <div dir="ltr">
          <div class="gmail_extra">
            <div class="gmail_quote">
              <blockquote class="gmail_quote" style="margin:0px 0px 0px
0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex"><span
                  class="">
                  <blockquote class="gmail_quote" style="margin:0px 0px
                    0px
0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex"><br>
                  </blockquote>
                </span> That style is my doing and my preference.   
                There remains differing opinions in the<br>
                group on the style and some consider the accessors
                wasted effort but I find them<br>
                useful often enough to prefer them.<br>
                <br>
                Jon<br>
                <blockquote class="gmail_quote" style="margin:0px 0px
                  0px
0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex"><br>
                </blockquote>
              </blockquote>
              <div><br>
              </div>
              <div>I saw this after reading runtime thread. Things are
                getting confused.</div>
              <div>We can do</div>
              <div><br>
              </div>
              <div>BlockFreelist *dictionary() { return
                &_dictionary; }</div>
              <div><br>
              </div>
              <div>and keep dictionary()->XXX</div>
              <div>This is actually consistent with
                _humongous_blocklist.</div>
              <div><br>
              </div>
              <div><a moz-do-not-send="true"
                  href="http://cr.openjdk.java.net/%7Ejwha/8079091/webrev.01">http://cr.openjdk.java.net/~jwha/8079091/webrev.01</a><br>
              </div>
              <div>current one has </div>
              <div>
                <div>BlockFreelist &dictionary() { return
                  _dictionary; }</div>
              </div>
              <div><br>
              </div>
              <div>and changed it to dictionary().XXX</div>
            </div>
          </div>
        </div>
      </blockquote>
      <br>
      Jungwoo,<br>
      <br>
      Sorry for the differing suggestions on our part.  I think Kim's
      point<br>
      was to not have the accessors.   I vote to (1) keep the accessors
      (which<br>
      are currently there) and  use (2)<br>
      <br>
      <blockquote type="cite">
        <div>BlockFreelist *dictionary() { return &_dictionary; }</div>
      </blockquote>
      <br>
      and the style dictionary()->XXX (to minimize changes).<br>
      <br>
      Kim,<br>
      <br>
      How about we let Jungwoo integrate with the style (1) and<br>
      (2) I outline above so he is not caught in the middle.  You<br>
      and I can talk about it on the side.<br>
    </blockquote>
    <br>
    I'm fine with letting him integrate with your suggestions, but I
    prefer Kim's suggestion.<br>
    <br>
    a) I don't see a need to expose a public accessor function to
    something that is private.<br>
    <br>
    b) The current code mixes the usage of the accessor function and the
    instance variable, which makes the code non-obvious:<br>
    <br>
      if (dictionary() == NULL) {<br>
       _dictionary = new BlockTreeDictionary();<br>
      }<br>
    <br>
    and forces the casual reader to go an look how dictionary() is
    implemented.<br>
    <br>
    I'd much prefer if the code was written as:<br>
      if (_dictionary == NULL) {<br>
       _dictionary = new BlockTreeDictionary();<br>
      }<br>
    <br>
    or at least:<br>
      if (dictionary() == NULL) {<br>
       set_dictionary(new BlockTreeDictionary());<br>
      }<br>
    <br>
    StefanK<br>
    <br>
    <br>
    <blockquote cite="mid:5541D310.2050800@oracle.com" type="cite"> <br>
      Jon<br>
      <br>
      <br>
      <blockquote
cite="mid:CA+n_jhjPN7KouhhDApc5miZkBGZ3oDwFSYnp0HLbYooMpb4BGg@mail.gmail.com"
        type="cite">
        <div dir="ltr">
          <div class="gmail_extra">
            <div class="gmail_quote">
              <div><br>
              </div>
              <div>Whichever you guys prefer...</div>
            </div>
          </div>
        </div>
      </blockquote>
      <br>
    </blockquote>
    <br>
  </body>
</html>