<html>
<head>
<meta content="text/html; charset=windows-1252"
http-equiv="Content-Type">
</head>
<body bgcolor="#FFFFFF" text="#000000">
<br>
<br>
<div class="moz-cite-prefix">On 03/02/2016 02:49 PM, Kim Barrett
wrote:<br>
</div>
<blockquote
cite="mid:268377DA-611A-4EFE-9091-327CCD383FBA@oracle.com"
type="cite">
<blockquote type="cite">
<pre wrap="">On Mar 2, 2016, at 3:09 PM, Jon Masamitsu <a class="moz-txt-link-rfc2396E" href="mailto:jon.masamitsu@oracle.com"><jon.masamitsu@oracle.com></a> wrote:
</pre>
</blockquote>
<pre wrap="">
Jon,
Thanks for looking at this.
</pre>
<blockquote type="cite">
<pre wrap=""><a class="moz-txt-link-freetext" href="http://cr.openjdk.java.net/~kbarrett/8150676/webrev.00/src/share/vm/gc/g1/dirtyCardQueue.hpp.frames.html">http://cr.openjdk.java.net/~kbarrett/8150676/webrev.00/src/share/vm/gc/g1/dirtyCardQueue.hpp.frames.html</a>
55 // Apply the closure to all active elements, from index to size. If
Change "size" to "_sz"? It's hard to understand what "size" is from only the
signature of apply_closure(). Using "_sz" gives a (weak) hint that the upper limit
is a field in the class.
</pre>
</blockquote>
<pre wrap="">
Same applies to index vs. _index. But size is at least an accessor
function. And while I dislike mentioning internals in a "doc"
comment, avoiding it here is probably harder than is useful. So
I'm updating the comment for both.</pre>
</blockquote>
<br>
Thanks.<br>
<blockquote
cite="mid:268377DA-611A-4EFE-9091-327CCD383FBA@oracle.com"
type="cite">
<pre wrap="">
</pre>
<blockquote type="cite">
<pre wrap=""> 69 static bool apply_closure_to_buffer(CardTableEntryClosure* cl,
Would "apply_closure_to_node" now be a better name?
</pre>
</blockquote>
<pre wrap="">
Not necessarily; the closure is to be applied to the node's buffer. [I
also have some more cleanups in development; I'm not sure this
function will survive in its current form.]</pre>
</blockquote>
<br>
Ok.<br>
<br>
<blockquote
cite="mid:268377DA-611A-4EFE-9091-327CCD383FBA@oracle.com"
type="cite">
<pre wrap="">
</pre>
<blockquote type="cite">
<pre wrap=""><a class="moz-txt-link-freetext" href="http://cr.openjdk.java.net/~kbarrett/8150676/webrev.00/src/share/vm/gc/g1/satbMarkQueue.cpp.frames.html">http://cr.openjdk.java.net/~kbarrett/8150676/webrev.00/src/share/vm/gc/g1/satbMarkQueue.cpp.frames.html</a>
</pre>
<blockquote type="cite">
<pre wrap=""> 129 if (retain_entry(entry, g1h)) {
130 // Found keeper. Search high to low for an entry to discard.
131 while ((src < --dst) && retain_entry(*dst, g1h)) { }
132 if (src >= dst) break; // Done if no discard found.
</pre>
</blockquote>
<pre wrap="">
If I'm at line 132 then "src" points to a keeper and is the lowest
(addressed) keeper. If that's true, then if "dst" is less than "src"
as seems to be allowed at line 132, then the index calculation
</pre>
<blockquote type="cite">
<pre wrap=""> 137 _index = pointer_delta(dst, buf, 1);
</pre>
</blockquote>
<pre wrap="">
seems like it will be off (too small).
</pre>
</blockquote>
<pre wrap="">
Recall that line 136 asserts (src == dst). Line 132 could equally well
be "if (src == dst) break;" followed by asserting (src < dst), but I'm
slightly less confident (or probably overly pessimistic) the compiler
would optimize that away.</pre>
</blockquote>
<br>
I stared a lot at the inequality in "if (src <font color="#ff0000">>=</font>
dst) break;" and could<br>
no decide whether the inequality was needed so drifted down to the<br>
consequences if the inequality was needed (hence my question).<br>
<br>
I would like "if (src == dst) break;" followed by asserting (src
< dst)<br>
better. Or move the assertion up under line 132 so I don't miss it<br>
the next time I look at this code.<br>
<br>
<blockquote
cite="mid:268377DA-611A-4EFE-9091-327CCD383FBA@oracle.com"
type="cite">
<pre wrap="">
As written state (dst < src) is not possible anywhere in this
algorithm, assuming the initial (_index <= _sz) invariant holds.
I tried several ways of writing this, including the addition of state
variables or using goto(!) (loop nests can be such a pain); what I
published seemed like the easiest to understand (for me, today, but I
might be too close to this code right now). I can provide some of
those alternatives for discussion if you wish.
One thing that makes it tricky is the aforesaid line 136 assertion,
which I found very helpful, but which requires some additional code
(such as line 132) to make it work. That is, this suffices,
for ( ; src < dst; ++src) {
if (retain_entry(entry, g1h)) {
while (src < --dst) {
if (!retain_entry(*dst, g1h)) {
*dst = entry;
break;
}
}
}
}
_index = pointer_delta(dst, buf, 1);
but I find it less convincing without the final assert, which doesn't
hold with this version.
</pre>
<blockquote type="cite">
<pre wrap=""><a class="moz-txt-link-freetext" href="http://cr.openjdk.java.net/~kbarrett/8150676/webrev.00/src/share/vm/gc/g1/ptrQueue.cpp.frames.html">http://cr.openjdk.java.net/~kbarrett/8150676/webrev.00/src/share/vm/gc/g1/ptrQueue.cpp.frames.html</a>
209 BufferNode* node = BufferNode::make_node_from_buffer(_buf, _index);
Move 209 above 190
190 if (_lock) {
and delete 222?
222 BufferNode* node = BufferNode::make_node_from_buffer(_buf, _index);
</pre>
</blockquote>
<pre wrap="">
I have another change in development that refactors things so that
this code movement would need to be undone.</pre>
</blockquote>
<br>
OK.<br>
<br>
Looks good.<br>
<br>
Jon<br>
<blockquote
cite="mid:268377DA-611A-4EFE-9091-327CCD383FBA@oracle.com"
type="cite">
<pre wrap="">
</pre>
</blockquote>
<br>
</body>
</html>