<html><head><style>body{font-family:Helvetica,Arial;font-size:13px}</style></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;"><div id="bloop_customfont" style="font-family:Helvetica,Arial;font-size:13px; color: rgba(0,0,0,1.0); margin: 0px; line-height: auto;">Thomas,</div><div id="bloop_customfont" style="font-family:Helvetica,Arial;font-size:13px; color: rgba(0,0,0,1.0); margin: 0px; line-height: auto;"><br></div><div id="bloop_customfont" style="font-family:Helvetica,Arial;font-size:13px; color: rgba(0,0,0,1.0); margin: 0px; line-height: auto;">Thanks for looking at it. Inline.</div> <br><p class="airmail_on">On April 21, 2016 at 7:01:39 AM, Thomas Schatzl (<a href="mailto:thomas.schatzl@oracle.com">thomas.schatzl@oracle.com</a>) wrote:</p> <div><blockquote type="cite" class="clean_bq" style="font-family: Helvetica, Arial; font-size: 13px; font-style: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: auto; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: auto; word-spacing: 0px; -webkit-text-stroke-width: 0px;"><span><div><div></div><div>Hi Tony,<span class="Apple-converted-space"> </span><br><br>On Wed, 2016-04-13 at 09:24 -0400, Tony Printezis wrote:<span class="Apple-converted-space"> </span><br>> Follow-up change to do preserved mark restoration in parallel in PS:<span class="Apple-converted-space"> </span><br>><span class="Apple-converted-space"> </span><br>> http://cr.openjdk.java.net/~tonyp/8154153/webrev.0/<span class="Apple-converted-space"> </span><br>><span class="Apple-converted-space"> </span><br>> I also changed the “Promotion failed” log message from:<span class="Apple-converted-space"> </span><br>> log_info(gc)("Promotion failed”);<span class="Apple-converted-space"> </span><br>> to:<span class="Apple-converted-space"> </span><br>> log_info(gc, promotion)("Promotion failed");<span class="Apple-converted-space"> </span><br>> to be consistent with the other GCs.<span class="Apple-converted-space"> </span><br>><span class="Apple-converted-space"> </span><br><br>- renaming of ParRestoreTask to ParRestoreGangTask: no other<span class="Apple-converted-space"> </span><br>AbstractGangTask child class has "Gang" in its name.<span class="Apple-converted-space"> </span><br><br>I can kind of see the name clashes with "ParRestoreGCTask", but I do<span class="Apple-converted-space"> </span><br>not think it really helps.<span class="Apple-converted-space"> </span></div></div></span></blockquote></div><p><br></p><p>Yeah, I renamed it to differentiate it a bit from ParRestoreGCTask. No strong opinion here. If you’re happy with ParRestoreTask / ParRestoreGCTask we can go with that.</p><p><br></p><div><div><blockquote type="cite" class="clean_bq" style="font-family: Helvetica, Arial; font-size: 13px; font-style: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: auto; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: auto; word-spacing: 0px; -webkit-text-stroke-width: 0px;"><span><div><div><br>Feel free to ignore this, but maybe thinking about this again yields<span class="Apple-converted-space"> </span><br>some better names.<span class="Apple-converted-space"> </span><br><br>- preservedMarks.cpp needs a memory/resourceArea.hpp include due to the<span class="Apple-converted-space"> </span><br>use of ResourceMark.<span class="Apple-converted-space"> </span></div></div></span></blockquote></div><p><br></p><p>OK.</p><p><br></p><div><div><blockquote type="cite" class="clean_bq" style="font-family: Helvetica, Arial; font-size: 13px; font-style: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: auto; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: auto; word-spacing: 0px; -webkit-text-stroke-width: 0px;"><span><div><div><br>- preservedMarks.cpp: line 118, maybe an extra CR makes the code look<span class="Apple-converted-space"> </span><br>less cramped.<span class="Apple-converted-space"> </span></div></div></span></blockquote></div><p><br></p><p>Between the name() and do_it() methods?</p><p><br></p><div><div><blockquote type="cite" class="clean_bq" style="font-family: Helvetica, Arial; font-size: 13px; font-style: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: auto; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: auto; word-spacing: 0px; -webkit-text-stroke-width: 0px;"><span><div><div><br>- preservedMarks.cpp: line 128: style: if argument list needs to be<span class="Apple-converted-space"> </span><br>split across multiple lines, we (in the gc team) favor one argument per<span class="Apple-converted-space"> </span><br>line.<span class="Apple-converted-space"> </span></div></div></span></blockquote></div><p><br></p><p>Sure, sounds good and I’ll keep that in mind in the future. Both at the method declaration and definition? Does that also apply to the initializer list?</p><p><br></p><div><div><blockquote type="cite" class="clean_bq" style="font-family: Helvetica, Arial; font-size: 13px; font-style: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: auto; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: auto; word-spacing: 0px; -webkit-text-stroke-width: 0px;"><span><div><div><br>- some copyrights need updates<span class="Apple-converted-space"> </span></div></div></span></blockquote></div><p><br></p><p>Will do. I’ll post a new version shortly.</p><p><br></p><p>Tony</p><p><br></p><div><blockquote type="cite" class="clean_bq" style="font-family: Helvetica, Arial; font-size: 13px; font-style: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: auto; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: auto; word-spacing: 0px; -webkit-text-stroke-width: 0px;"><span><div><div><br>I will run it through jprt/some tests.<span class="Apple-converted-space"> </span><br><br>Thanks,<span class="Apple-converted-space"> </span><br>Thomas<span class="Apple-converted-space"> </span><br><br></div></div></span></blockquote><br class="Apple-interchange-newline"></div><br class="Apple-interchange-newline"></div><br class="Apple-interchange-newline"></div><br class="Apple-interchange-newline"></div><br class="Apple-interchange-newline"></div> <div id="bloop_sign_1461240198841889792" class="bloop_sign"><div style="font-family:helvetica,arial;font-size:13px"><div>-----</div><div><br></div><div>Tony Printezis | JVM/GC Engineer / VM Team | Twitter</div><div><br></div><div>@TonyPrintezis</div><div><a href="mailto:tprintezis@twitter.com">tprintezis@twitter.com</a></div><div><br></div></div></div></body></html>