RFR: 8216995: Clean up JFR command line processing

Gerard Ziemski gerard.ziemski at oracle.com
Mon Jan 14 19:19:23 UTC 2019


hi Claes,

Looks good.

If I had to change anything, then in "src/hotspot/share/jfr/recorder/jfrRecorder.cpp" I would probably prefer to see something like:

+  FLAG_SET_MGMT(bool, FlightRecorder, true);
+  _enabled = FlightRecorder;
+  assert(_enabled == true, “must be");

instead of:

+  FLAG_SET_MGMT(bool, FlightRecorder, true);
+  _enabled = true;


cheers


> On Jan 14, 2019, at 11:33 AM, Claes Redestad <claes.redestad at oracle.com> wrote:
> 
> Hi,
> 
> JFR setup could be simplified by using macros defined
> in globals_extension.hpp rather than use JVMFlag directly.
> 
> On top of looking cleaner this avoids JVMFlag::find_flag, which does a
> linear scan of all flags. So a tiny startup optimization (detectable
> only with special goggles).
> 
> Webrev: http://cr.openjdk.java.net/~redestad/8216995/open.00/
> Bug:    https://bugs.openjdk.java.net/browse/JDK-8216995
> 
> Testing: tier1-2 (ongoing)
> 
> Thanks!
> 
> /Claes



More information about the hotspot-jfr-dev mailing list