Request for review: 7034585 Adjust fillinStackTrace filtering to assist 6998871
David Holmes
David.Holmes at oracle.com
Mon Apr 11 16:54:49 PDT 2011
Tom, Mandy,
Can I get the ok on the revised webrev please. I'd like to push this today.
Thanks,
David
David Holmes said the following on 04/09/11 15:05:
> Tom Rodriguez said the following on 04/09/11 10:03:
>> On Apr 8, 2011, at 5:01 PM, David Holmes wrote:
>>
>>> Tom Rodriguez said the following on 04/09/11 09:22:
>>>> Actually why are you checking for fillInStackTrace* instead of just
>>>> fillInStackTrace?
>>>> if (method->name() == vmSymbols::fillIinStackTrace_name() &&
>>>> throwable->is_a(method->method_holder())) {
>>> Added flexibility. There is still some debate as to the final naming
>>> scheme in the JDK changes. At present an overload of fillInStackTrace
>>> is used with a dummy int parameter. The normal naming scheme would
>>> have the native method be called fillInStackTrace0. That would have
>>> required a VM change, hence the overload. But we ended up needing a
>>> VM change anyway, hence it is now possible to change the method name.
>>> I was trying to accommodate this either way. But perhaps it is
>>> simpler to just add the symbol for fillInStackTrace0 and check for
>>> either?
>>
>> I think that would be more straightforward.
>
> Agreed. Updated webrev:
>
> http://cr.openjdk.java.net/~dholmes/7034585/webrev.2/
>
> Thanks,
> David
> ------
>
More information about the hotspot-runtime-dev
mailing list