RFR (XS): 8004661: Comment and function name java_lang_String::toHash is wrong

Erik Helin erik.helin at oracle.com
Wed Dec 12 05:42:14 PST 2012


On 12/12/2012 01:15 PM, Bengt Rutisson wrote:
> Shouldn't the method be called hash_code() rather than hashCode() ?

This is the standard we use throughout the codebase for the C++ code, 
but I believe that the Coleen wanted the name of the method to match the 
Java one.

Coleen, did I understand this correctly?

I'm fine with using any one of hashCode or hash_code, I think both 
suggestions make sense.

On 12/12/2012 01:15 PM, Bengt Rutisson wrote:
> Other than that it looks good to me.



> Bengt
> On 12/12/12 10:27 AM, Erik Helin wrote:
>> Hi all,
>> the webrev is located at:
>> http://cr.openjdk.java.net/~ehelin/8004661/webrev.00/
>> Bug:
>> http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=8004661
>> Summary:
>> I've renamed the function to_hash to hashCode and also updated the
>> comments to use hashCode instead of to_hash.
>> Testing:
>> Thanks,
>> Erik

More information about the hotspot-runtime-dev mailing list