RFR JDK-8039525: HashTable lookup API needs refactoring

John Rose john.r.rose at oracle.com
Fri Apr 25 00:23:17 UTC 2014

Three comments:

1. Yay!  I have a soft spot for this kind of change.

2. You apparently added a blank-carrying line in symbolTable.hpp.  jcheck will stop you from committing it.

3. Please get rid of "probe*" while you are at it, or at least pick a name which fits in your new scheme.  IIRC it was an incursion from a non-runtime programmer.


— John

On Apr 24, 2014, at 1:59 PM, Gerard Ziemski <gerard.ziemski at oracle.com> wrote:

> hi all,
> Please review this simple enhancement, which renames symbolTable::lookup API using names that better reflect the method purpose, ie: lookup_only, lookup_and_add, lookup_only_and_hash, lookup_and_add_unicode and lookup_only_and_hash_unicode.
> No new or removed code.
> Webrev: http://cr.openjdk.java.net/~gziemski/8039525_rev0
> Bug: https://bugs.openjdk.java.net/browse/JDK-8039525
> Tested with hotspot jtreg, vm.quicklooks and JPRT. Locally builds on Mac OS X and Linux.
> Thank you.

More information about the hotspot-runtime-dev mailing list