RFR(XXS) 8068592 Remove unused code in objectMonitor.hpp
Daniel D. Daugherty
daniel.daugherty at oracle.com
Wed Jun 8 20:37:21 UTC 2016
Done pulling the loose thread:
Webrev URL:
http://cr.openjdk.java.net/~dcubed/8068592-webrev/1-jdk9-hs-hotspot/
This version changes three files:
src/share/vm/runtime/objectMonitor.cpp
src/share/vm/runtime/objectMonitor.hpp
src/share/vm/runtime/synchronizer.hpp
We've gone from 12 lines changed (mostly deletes)
to 34 lines changed (still mostly deletes); still
considering this one to "XXS"...
Passes JPRT test builds...
Thanks, in advance, for any comments, suggestions or feedback.
Dan
On 6/8/16 8:54 AM, Daniel D. Daugherty wrote:
> At the risk of pulling the loose thread on the sweater, I'll take a look
> at the two BTWs below... :-)
>
> Dan
>
>
> On 6/7/16 5:01 PM, David Holmes wrote:
>> BTW you could (but don't have to) get rid of this in objectMonitor.cpp
>>
>> #define TrySpin TrySpin_VaryDuration
>>
>> and rename TrySpin_Duration to TrySpin, now there are no other
>> options to select.
>>
>> BTW2: You might also grep for SpinCallback - there seems to be some
>> infrastructure for that unused facility as well.
>>
>> David
>>
>> On 8/06/2016 7:01 AM, David Holmes wrote:
>>> Hi Dan,
>>>
>>> Looks good. I agree this is all unused.
>>>
>>> Thanks,
>>> David
>>>
>>> On 8/06/2016 6:55 AM, Daniel D. Daugherty wrote:
>>>> Greetings,
>>>>
>>>> I have a fix ready for the following RFE:
>>>>
>>>> JDK-8068592 Remove unused code in objectMonitor.hpp
>>>> https://bugs.openjdk.java.net/browse/JDK-8068592
>>>>
>>>> Yes, this an RFE and I'm fixing it now for a few reasons:
>>>>
>>>> 1) I promised Claes Redestad back on 04.25 that this would be the
>>>> first
>>>> issue I worked on when I got my Solaris-X64 environment back.
>>>> mt-haku
>>>> is now running Solaris 11.2 SRU5.5 so it is back!
>>>>
>>>> 2) This is the simplest change in my queue with little to no risk
>>>> so it
>>>> makes the perfect test case for my upgrade of mt-haku from Solaris
>>>> 10u11 -> Solaris 11.2 SRU5.5.
>>>>
>>>> 3) This change gets rid of unused fields, unused macro assembler
>>>> functions
>>>> and a couple of declared but not defined functions from
>>>> ObjectMonitor.
>>>> Slimming down ObjectMonitor is never a bad thing!
>>>>
>>>> Yes, I know that the process for getting approval for RFEs is not yet
>>>> defined. However, I want to get the code review out of the way so that
>>>> this changeset can go in if it is approved.
>>>>
>>>> Sanity check: I searched a JDK9-hs clone for the following patterns:
>>>>
>>>> FreeNext_offset_in_bytes
>>>> Responsible_offset_in_bytes
>>>> Spinner_offset_in_bytes
>>>> TrySpin_Fixed
>>>> TrySpin_VaryFrequency
>>>> WaitSet_offset_in_bytes
>>>> _SpinClock
>>>> _SpinFreq
>>>> _SpinState
>>>>
>>>> and found no mentions outside of the ones that I'm deleting from
>>>> src/share/vm/runtime/objectMonitor.hpp.
>>>>
>>>> Webrev URL:
>>>> http://cr.openjdk.java.net/~dcubed/8068592-webrev/0-jdk9-hs-hotspot/
>>>>
>>>> Testing: JPRT test builds are in process.
>>>>
>>>> Thanks, in advance, for any comments, suggestions or feedback.
>>>>
>>>> Dan
>
>
More information about the hotspot-runtime-dev
mailing list