RFR 8180325: Use ClassLoaderData::classes_do for CDS classes

coleen.phillimore at oracle.com coleen.phillimore at oracle.com
Fri May 12 22:46:55 UTC 2017


Summary: Use closures and ClassLoaderData::classes_do instead of 
SystemDictionary::classes_do

Migrate CDS code to ClassLoaderData::loaded_classes_do.  The 
loaded_classes_do function should be called without a lock, like the 
rest of the ClassLoaderData::classes_do functions.  Also, I didn't 
filter anonymous classes with the CDS functions because at the moment, 
we don't encounter them (there's an assert).  If the code changes so 
that we do encounter them, we might want to link them or decide what to 
do with them at that time.

open webrev at http://cr.openjdk.java.net/~coleenp/8180325.01/webrev
bug link https://bugs.openjdk.java.net/browse/JDK-8180325

Tested with nightly rbt run on linux x86, including and additionally all 
the CDS tests locally.

Thanks,
Coleen



More information about the hotspot-runtime-dev mailing list