RFR(M) 8191375 Add high-level jtreg VMProps to filter out CDS tests
Jiangli Zhou
jiangli.zhou at Oracle.COM
Thu Feb 15 19:11:04 UTC 2018
Hi Ioi,
HeapRegion is ambiguous. How about renaming WB_areHeapRegionsSupportedByCDS() to WB_isJavaHeapArchiveSupportedByCDS() or just WB_isJavaHeapArchiveSupported()?
And rename vm.cds.archived.heap to vm.cds.archived.java.heap, vmCDSForArchivedHeap() to vmCDSForArchivedJavaHeap()?
You can remove the following line from OpenArchiveRegion.java.
29 * @requires (vm.gc=="null")
The rest looks good.
Thanks,
Jiangli
> On Feb 15, 2018, at 4:55 AM, Ioi Lam <ioi.lam at oracle.com> wrote:
>
> https://bugs.openjdk.java.net/browse/JDK-8191375
> http://cr.openjdk.java.net/~iklam/jdk11/8191375-cds.tests.vmprop.v01/
>
> Summary:
>
> 1. Added the new property "@require vm.cds.archived.heap". This replaces various
> ad-hoc settings like the following, which is hard to maintain:
>
> * Feature support: G1GC only, compressed oops/kptrs, 64-bit os, not on windows
> * @requires (sun.arch.data.model != "32") & (os.family != "windows")
> * @requires vm.cds
> * @requires vm.gc.G1
>
>
> 2. Also did some clean up such as removing duplicated lines of "@require vm.cds"
> in some tests
>
> 3. Removed explicit settings of -XX:-UseCompressedOops, -XX:+UseGCGC, etc, that
> are now implied by "@require vm.cds" or "@require vm.cds.archived.heap"
>
> 4. Removed unnecessary '@require vm.gc == "null"' from a few test cases.
> (It is only needed by tests that explicitly choose GC types, but somehow it's
> been leaked to other tests due to copy-paste).
>
> I've tested locally with jtreg:
>
> - no explicit setting of GC
> - explicitly set GC with -vmoptions:-XX:+UseG1GC
> - explicitly set GC with -vmoptions:-XX:+UseParallelGC
>
> Testing with mach5 with tiers 1-3 now.
>
> Thanks
> - Ioi
More information about the hotspot-runtime-dev
mailing list