RFR(XXS) 8199741: NMT: Tag safepoint polling pages

Zhengyu Gu zgu at redhat.com
Fri Mar 16 16:05:15 UTC 2018



On 03/16/2018 11:50 AM, coleen.phillimore at oracle.com wrote:
> 
> Yay, a quick code review.  Is there a better mt tag than mtInternal 

Thanks, Coleen.


> though?  There are too many mtInternal allocations.  Can you add 
> mtSafepoint or mtSynchronize (or better name?) and we could have an RFE 
> to make some of these into the same:
> 
> share/runtime/semaphore.hpp:class Semaphore : public CHeapObj<mtInternal> {
> share/runtime/mutex.hpp:class Monitor : public CHeapObj<mtInternal> {
> share/runtime/objectMonitor.cpp:  return AllocateHeap(size, mtInternal);
> share/runtime/objectMonitor.cpp:  char * knobs = (char *) os::malloc(sz 
> + 2, mtInternal);
> share/runtime/monitorChunk.cpp:  _monitors           = 
> NEW_C_HEAP_ARRAY(BasicObjectLock, number_on_monitors, mtInternal);
> 
> Or even mtOS so we can move some of the os allocations to this category?

Of course, we can have as many as 255 categories, another RFE?


-Zhengyu

> 
> Why is nothing simple?! :)
> 
> Coleen
> 
> On 3/16/18 11:34 AM, Zhengyu Gu wrote:
>> A trivial fix to add NMT tag to Safepoint poll pages.
>>
>> Bug: https://bugs.openjdk.java.net/browse/JDK-8199741
>> Webrev: http://cr.openjdk.java.net/~zgu/8199741/webrev.00/
>>
>> Test:
>>   Eyeball NMT output on Linux x64.
>>
>> Thanks,
>>
>> -Zhengyu
> 


More information about the hotspot-runtime-dev mailing list