RFR(XXS) 8199741: NMT: Tag safepoint polling pages

Zhengyu Gu zgu at redhat.com
Fri Mar 16 16:27:16 UTC 2018


Filed separate RFE to breakup overused mtInternal.

https://bugs.openjdk.java.net/browse/JDK-8199746

Thanks,

-Zhengyu

On 03/16/2018 11:50 AM, coleen.phillimore at oracle.com wrote:
> Yay, a quick code review.  Is there a better mt tag than mtInternal 
> though?  There are too many mtInternal allocations.  Can you add 
> mtSafepoint or mtSynchronize (or better name?) and we could have an RFE 
> to make some of these into the same:
> 
> share/runtime/semaphore.hpp:class Semaphore : public CHeapObj<mtInternal> {
> share/runtime/mutex.hpp:class Monitor : public CHeapObj<mtInternal> {
> share/runtime/objectMonitor.cpp:  return AllocateHeap(size, mtInternal);
> share/runtime/objectMonitor.cpp:  char * knobs = (char *) os::malloc(sz 
> + 2, mtInternal);
> share/runtime/monitorChunk.cpp:  _monitors           = 
> NEW_C_HEAP_ARRAY(BasicObjectLock, number_on_monitors, mtInternal);
> 
> Or even mtOS so we can move some of the os allocations to this category?
> 
> Why is nothing simple?! :)


More information about the hotspot-runtime-dev mailing list