RFR(XS) 8230011 Consolidate duplicated classpath parsing code in classLoader.cpp
Frederic Parain
frederic.parain at oracle.com
Thu Aug 22 15:59:31 UTC 2019
Ioi,
ClasspathStream makes this code easier to read, but for the sake of
readability, could the test at line 190 be more explicit:
190 while (_class_path[_end] && _class_path[_end] != os::path_separator()[0]) {
It could be written like this:
190 while (_class_path[_end] != ‘\0' && _class_path[_end] != os::path_separator()[0]) {
in order to avoid the implied boolean.
Thank you,
Fred
> On Aug 22, 2019, at 00:23, Ioi Lam <ioi.lam at oracle.com> wrote:
>
> https://bugs.openjdk.java.net/browse/JDK-8230011
> http://cr.openjdk.java.net/~iklam/jdk14/8230011-consolidate-classpath-parsing.v01/
>
> Summary: moved the duplicated code into a single place: ClasspathStream
>
> Thanks
> - Ioi
More information about the hotspot-runtime-dev
mailing list