RFR (S) 8248240: Remove extendedPC.hpp and fetch_frame_from_ucontext
coleen.phillimore at oracle.com
coleen.phillimore at oracle.com
Thu Jun 25 00:19:41 UTC 2020
On 6/24/20 7:27 PM, David Holmes wrote:
> On 25/06/2020 9:17 am, coleen.phillimore at oracle.com wrote:
>> On 6/24/20 7:11 PM, David Holmes wrote:
>>> Hi Coleen,
>>>
>>> This cleanup looks good - thanks.
>>>
>>> My only query (from existing code) is why something called
>>> "fetch_frame" doesn't actually return a frame ??
>>
>> Thanks David.
>>
>> http://cr.openjdk.java.net/~coleenp/2020/8248240.01/webrev/src/hotspot/os_cpu/aix_ppc/os_aix_ppc.cpp.udiff.html
>>
>>
>> Looks like one of these overloads does return the frame, and the
>> other returns the pieces of a frame. No idea.
>
> I think fetch_frame_from_ucontext was misnamed given it didn't return
> a frame. Now we have actual overloads of fetch_frame_from_context that
> return completely different types. That looks odd to me. Possible
> future cleanup.
I agree. If somebody looks at the entirety of the code that uses these
functions:
// - Forte Analyzer: AsyncGetCallTrace()
// - StackBanging: get_frame_at_stack_banging_point()
they can rename the functions to make more sense (or fix the one to
return frame).
Thanks,
Coleen
>
> David
>
>> Thanks
>> Coleen
>>
>>>
>>> Thanks,
>>> David
>>>
>>> On 25/06/2020 7:08 am, coleen.phillimore at oracle.com wrote:
>>>> Summary: This empty interface was left over from deleting code from
>>>> before safepoint polling.
>>>>
>>>> See bug for details. Ran tier1-3, and also builds on ppc, aarch64,
>>>> arm, s390, and zero.
>>>>
>>>> open webrev at
>>>> http://cr.openjdk.java.net/~coleenp/2020/8248240.01/webrev
>>>> bug link https://bugs.openjdk.java.net/browse/JDK-8248240
>>>>
>>>> Thanks,
>>>> Coleen
>>
More information about the hotspot-runtime-dev
mailing list