RFR: JDK-8254189: Improve comments for StackOverFlow and fix in_xxx() functions

David Holmes dholmes at openjdk.java.net
Tue Oct 27 01:36:17 UTC 2020


On Thu, 22 Oct 2020 04:21:30 GMT, Thomas Stuefe <stuefe at openjdk.org> wrote:

> Hi,
> 
> may I please have reviews for this small cleanup / fix?
> 
> While reviewing JDK-8253717 it was found that comments would help with understanding the StackOverFlow class. Especially the fact that the various _base_ are actually pointing outside their respective zone, since the stack grows downward and a zone (and the stack itself) range is [end, base). If you don't look at this code daily it can be surprising.
> 
> This also fixes some small off-by-one errors in various "in_stack_xxx_zone()" methods which test whether a given address is inside a zone and gave wrong results for address=base since base points outside its zone. This had the effect that an address could be in multiple zones.
> 
> Finally it adds a small gtest which tests the StackOverFlow methods.

Hi Thomas,

Seems okay.

One nit below.

Thanks,
David

src/hotspot/share/runtime/stackOverflow.cpp line 44:

> 42:   // Note: Zone sizes are given via Stack(Red|Yellow|Reserved|Shadow)Pages
> 43:   //  parameters; these names are misleading since they actually contain
> 44:   //  zone size in units-of-4K-size, regardless the actual platform page size,

s/regardless the/regardless of the/

But this is already covered by the following comment:

  // We need to adapt the configured number of stack protection pages given
  // in 4K pages to the actual os page size. We must do this before setting

-------------

Marked as reviewed by dholmes (Reviewer).

PR: https://git.openjdk.java.net/jdk/pull/795


More information about the hotspot-runtime-dev mailing list