RFR: 8255489: Unify the parsing of @lambda-proxy and @lambda-form-invokers tags in a classlist
Yumin Qi
minqi at openjdk.java.net
Thu Oct 29 20:08:44 UTC 2020
On Thu, 29 Oct 2020 19:11:32 GMT, Calvin Cheung <ccheung at openjdk.org> wrote:
> With this change, the parsing of the `@lambda-proxy` and the `@lambda-form-invokers` tags in a classlist will be performed in the same function - `ClassListParser::parse_at_tags()`.
>
> Also removing the `:` of the `@lambda-proxy:` to be consistent with the `@lambda-form-invokers `tag.
>
> Ran tiers 1 through 4 tests successfully.
Looks good to me. There are two issues in question:
1) _indy_items is specific name, it was designed for indy before and now it includes lambda_form_invokers. I don't know if we should use a more generic name here.
2) This part seems not necessary since we already done this before calling parse_at_tag:
211 } else if (strcmp(_indy_items->at(0), LAMBDA_FORM_TAG) == 0) {
212 for (int i = _line_len; i >= 0; i--) {
213 if (_line[i] == '\0') {
214 _line[i] = ' ';
215 }
216 }
-------------
PR: https://git.openjdk.java.net/jdk/pull/942
More information about the hotspot-runtime-dev
mailing list