RFR: 8252661: Change SafepointMechanism terminology to talk less about "blocking"
Erik Österlund
erik.osterlund at oracle.com
Tue Sep 1 15:53:18 UTC 2020
Hi,
The SafepointMechanism class has been used to perform safepoint
operations, originally.
Now we also perform handshake operations, and soon also concurrent stack
processing, using
the same hooks. Therefore, names such as
SafepointMechanism::should_block no longer sound
right, when the real question is whether it should process a pending
operation (be that a
safepoint, handshake or whatever else).
Naming is hard, so I don't want this discussion in my concurrent stack
processing patch.
I have a webrev with proposed naming changes to better reflect how this
is used:
http://cr.openjdk.java.net/~eosterlund/8252661/webrev.00/
Bug:
https://bugs.openjdk.java.net/browse/JDK-8252661
Thanks,
/Erik
More information about the hotspot-runtime-dev
mailing list