RFR: 8263632: Improve exception handling of APIs in classLoader.cpp
Calvin Cheung
ccheung at openjdk.java.net
Thu Mar 25 18:48:41 UTC 2021
Please review this change which includes:
- adding `ClassLoader::create_class_path_entry_or_fail()` and `ClassLoader::create_class_path_entry_or_fail()` functions for better readability. They will call the existing `ClassLoader::create_class_path_entry()`.
- replacing the TRAPS parameter with `Thread* current` for the functions which never throw exception.
Testing: tiers 1,2 (passed); tiers 3,4 (in progress).
-------------
Commit messages:
- 8263632: Improve exception handling of APIs in classLoader.cpp
Changes: https://git.openjdk.java.net/jdk/pull/3203/files
Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=3203&range=00
Issue: https://bugs.openjdk.java.net/browse/JDK-8263632
Stats: 54 lines in 6 files changed: 24 ins; 6 del; 24 mod
Patch: https://git.openjdk.java.net/jdk/pull/3203.diff
Fetch: git fetch https://git.openjdk.java.net/jdk pull/3203/head:pull/3203
PR: https://git.openjdk.java.net/jdk/pull/3203
More information about the hotspot-runtime-dev
mailing list