RFR: 8263632: Improve exception handling of APIs in classLoader.cpp [v2]
Coleen Phillimore
coleenp at openjdk.java.net
Fri Mar 26 16:24:31 UTC 2021
On Fri, 26 Mar 2021 16:11:45 GMT, Calvin Cheung <ccheung at openjdk.org> wrote:
>> Please review this change which includes:
>>
>> - adding `ClassLoader::create_class_path_entry_or_fail()` and `ClassLoader::create_class_path_entry_or_fail()` functions for better readability. They will call the existing `ClassLoader::create_class_path_entry()`.
>> - replacing the TRAPS parameter with `Thread* current` for the functions which never throw exception.
>>
>> Testing: tiers 1,2 (passed); tiers 3,4 (in progress).
>
> Calvin Cheung has updated the pull request incrementally with one additional commit since the last revision:
>
> get rid of throw_exception in ClassLoader::create_class_path_entry
Looks good.
src/hotspot/share/classfile/classLoader.cpp line 519:
> 517: Arguments::assert_is_dumping_archive();
> 518:
> 519: ResourceMark rm;
You can add 'current' as a parameter to ResourceMark since you have it.
-------------
Marked as reviewed by coleenp (Reviewer).
PR: https://git.openjdk.java.net/jdk/pull/3203
More information about the hotspot-runtime-dev
mailing list