Integrated: 8263632: Improve exception handling of APIs in classLoader.cpp

Calvin Cheung ccheung at openjdk.java.net
Fri Mar 26 21:33:26 UTC 2021


On Thu, 25 Mar 2021 18:42:37 GMT, Calvin Cheung <ccheung at openjdk.org> wrote:

> Please review this change which includes:
> 
> -  adding `ClassLoader::create_class_path_entry_or_fail()` and `ClassLoader::create_class_path_entry_or_fail()` functions for better readability. They will call the existing `ClassLoader::create_class_path_entry()`.
> - replacing the TRAPS parameter with `Thread* current` for the functions which never throw exception.
> 
> Testing: tiers 1,2 (passed); tiers 3,4 (in progress).

This pull request has now been integrated.

Changeset: c9d2d024
Author:    Calvin Cheung <ccheung at openjdk.org>
URL:       https://git.openjdk.java.net/jdk/commit/c9d2d024
Stats:     136 lines in 8 files changed: 11 ins; 37 del; 88 mod

8263632: Improve exception handling of APIs in classLoader.cpp

Reviewed-by: iklam, dholmes, coleenp

-------------

PR: https://git.openjdk.java.net/jdk/pull/3203


More information about the hotspot-runtime-dev mailing list