RFR: 8271569: Clean up the use of CDS constants and field offsets [v5]
Yumin Qi
minqi at openjdk.java.net
Tue Sep 14 16:58:41 UTC 2021
> Changed cdsOffsets.cpp to cdsConstants.cpp, now the offsets and constants are initialized static and searched separately.
> The offsets array could not use 'constexpr' since g++ on MacOs and VSC++ on Windows complained reinterpret_cast in 'offset_of' should not be used in constexpr initialization. Changed some field access for forming global list first.
>
> Note with 'git mv' to rename cdsoffset.cpp to cdsConstants.cpp, same for cdsoffsets.hpp to cdsConstants.hpp, due to the contents changed more than 50% so git will not think cdsConstants.cpp is renamed from cdsoffsets.cpp. Instead, it is regarded as a new file.
>
> Tests: ter1-4
>
> Thanks
> Yumin
Yumin Qi has updated the pull request incrementally with one additional commit since the last revision:
remove including <cstddef>, instead include globalDefinitions.hpp explicitly
-------------
Changes:
- all: https://git.openjdk.java.net/jdk/pull/5450/files
- new: https://git.openjdk.java.net/jdk/pull/5450/files/4f045e35..5eaf079b
Webrevs:
- full: https://webrevs.openjdk.java.net/?repo=jdk&pr=5450&range=04
- incr: https://webrevs.openjdk.java.net/?repo=jdk&pr=5450&range=03-04
Stats: 2 lines in 1 file changed: 1 ins; 1 del; 0 mod
Patch: https://git.openjdk.java.net/jdk/pull/5450.diff
Fetch: git fetch https://git.openjdk.java.net/jdk pull/5450/head:pull/5450
PR: https://git.openjdk.java.net/jdk/pull/5450
More information about the hotspot-runtime-dev
mailing list