RFR: 8281314: Rename Stack{Red,Yellow,Reserved,Shadow}Pages multipliers to "unit"
Aleksey Shipilev
shade at openjdk.java.net
Mon Feb 7 07:35:32 UTC 2022
This was a question during [JDK-8072070](https://bugs.openjdk.java.net/browse/JDK-8072070) review. The code in `StackOverflow::initialize_stack_zone_sizes()` multiplies `Stack{Red,Yellow,Reserved,Shadow}Pages` by "alignment", while that is actually just a "unit".
product_pd(intx, StackYellowPages, \
"Number of yellow zone (recoverable overflows) pages of size " \
"4KB. If pages are bigger yellow zone is aligned up.") \
range(MIN_STACK_YELLOW_PAGES, (DEFAULT_STACK_YELLOW_PAGES+5)) \
We can rename it for clarity.
-------------
Commit messages:
- Fix
Changes: https://git.openjdk.java.net/jdk/pull/7362/files
Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=7362&range=00
Issue: https://bugs.openjdk.java.net/browse/JDK-8281314
Stats: 5 lines in 1 file changed: 0 ins; 0 del; 5 mod
Patch: https://git.openjdk.java.net/jdk/pull/7362.diff
Fetch: git fetch https://git.openjdk.java.net/jdk pull/7362/head:pull/7362
PR: https://git.openjdk.java.net/jdk/pull/7362
More information about the hotspot-runtime-dev
mailing list